Author Topic: SP freezes when loading a new mesh  (Read 423 times)

I'm running into an issue where SP freezes the moment I bring a new mesh in (either from the new project dialog, or from the project configuration dialog). I'm exporting the meshes from Blender 2.80, but I'm running into issues with stuff from Maya and from the engine I'm using. It also doesn't matter if the file is an FBX or an OBJ, it fails either way. I also tried DAE, but the same issue persists.

I tried to reinstall the software, but no dice. I also tried installing older versions, and that didn't work either. Finally just to be sure, I erased my system drive and installed Windows 10 from scratch. I was able to make one project, after which it went back to freezing. This issue has me completely stumped!

Repro:
Load a mesh either via the new project dialog, or load a new mesh in in the project configuration dialog.

Hi,

Thanks for reaching out to us.

Do you think you could send me both your project which you are having problems with and your mesh so I could try both re-importing and creating a new project on my side? You can either do it through Wetransfer, Drive or Dropbox and give me the link.

Valeria Gerontopoulos
QA Analyst

I can't send you any of the proper projects I'm working on for confidentiality reasons, but I did make a mesh that failed. I can't send you an spp because I'm unable to do anything after opening a model (such as saving)

FBX file:
https://drive.google.com/open?id=1AyQXNwwRCKU24ozIB9sfFynJvUXOIkKP

Addendum: I can open files from other computers, but if I select a mask it freezes.

Hi,

Sorry for the wait. I was trying to reproduce your issue, but no luck so far.

I do not think it is driver related, but have you tried updating and/or downgrading your Nvidia drivers to see if it makes any difference? You can find a list of all drivers here: https://www.nvidia.fr/Download/Find.aspx

Are you storing your project(s) on a server/cloud? You would have probably mentioned it, but are you using remote access?

Are you on a multi-GPU setup?

What happens after SP freezes? Does it stay frozen indefinitely? If not, how long does it take it to unfreeze? If it crashes, could you attach your callstack as well? You should get it alongside your log by email when you check Send Additional Information box in the crash reporter window.
Valeria Gerontopoulos
QA Analyst

Sorry for the late response! Yeah I've tried updating/downgrading drivers, no luck. I'm not using a remote desktop, not doing cloud/server stuff.

The freeze lasts indefinitely - I left it overnight once to see if it would recover, and it did not. It doesn't crash; I have to manually kill it either through task manager, or by triggering windows' "The program has stopped responding" thinger.

Hi again,

I see your TDR is currently at 60 seconds. Could you change it back to 2 seconds? In case you need a reminder, that's how it is done: https://docs.substance3d.com/spdoc/gpu-drivers-crash-with-long-computations-128745489.html 

This will allows us to see whether the calculation is stuck in a loop.

Let me know if it is crashing instead of freezing with the 2 seconds!
Valeria Gerontopoulos
QA Analyst

I reduced the TDR to 2 seconds, and it's still frozen. No crash, unfortunately.

Hey again,

Are you able to load and paint on our sample projects, like the meetmat? It is just to make sure that your GPU works correctly.

Do you have issues with any other software, like UE4, Maya, Blender, etc. ?

Also, could you reattach your new log (after you changed your TDR)?

Thanks!
Valeria Gerontopoulos
QA Analyst

I can't do anything with the example project "meetmat", unfortunately. Same issue. I also updated to the latest version of Painter, and still nothing.

I've never had any problems with other software - I use Blender, and that works, as does our in-house engine.

I've attached the new log. Thanks for your help with this, I realize it's a tricky situation so I really appreciate it!

It looks like the new log is missing, can you attach it again ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Here you go!

edit: for some reason it's not attaching. I'll keep trying

let's see if this works

Can you run any other 3D application without issues ? Like video games ?
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Yep, everything else works! DCC apps, videogames, even VR. Incidentally, I have tried three different GPUs just to be sure, and none of them solved the issue, so unless I'm extraordinarily unlucky, I don't think it's a GPU thing.