Author Topic: "LAYERS" panel problem  (Read 3120 times)

Hello everyone,

I've a huge issue regarding the Layers panel. I can not, in most cases, move up or down any folder/layer. Meaning I can't reorder my layers if I wanna put upside/downside one another. Even if I'm able to, the layer I'm trying to move (I hold left click and move it up or down), Substance Painter moves the one above or lower instead... I have no idea what to do. It's so frustrating considering the fact that it blows up my projects and I don't have any control over that.

Thanks for understanding and I hope I can get this sorted soon.

PS: the filers, generators, Levels, etc work fine.


Thanks for reaching out to us.

Could you please attach your log? You can see how to do it here:

Also, if possible, could you either make a small video or a gif so it is easier to see the issue?

Thanks in advance!
Valeria Gerontopoulos
Product Designer | 3D Artist

Hello Valeria,

Thanks for your reply. :) I attached the log file.

Here's a video:
I tried several new projects, and it's still the same thing.
As you can see, I can either not move layers or move the wrong one. I have no idea what's causing this.

Thanks for understanding! :)



Sorry it took some time to get back to you, I was trying to reproduce your issue on my end, but I haven't managed to so far.

I don't think that it is a driver related issue, but have you tried updating your drivers? You can find all of them here

Could you send me the project you have the issue with? It would be just to see if it is project related and I can reproduce it on my end, or whether it is related to your system somehow.

Also have you tried reinstalling Substance Painter?
Valeria Gerontopoulos
Product Designer | 3D Artist


Thanks for getting back to the topic. I always have the latest GPU driver so it's not an issue of a driver.
I haven't actually tried reinstalling Painter. I'll try that.

I'd send the project but it's 11GB so it's gonna be hard to share. :)
However, I started a lot of new projects with different props/Substance spheres, tile and MAT to see, and the problem is always there.

So I'm gonna try reinstalling Painter now, and see if the problem is still there. And I'll let you know.


So I uninstalled Substance Painter, removed every designated folder and then reinstalled again. Still the same problem.

So I have no idea what to do now...

do you have two screens with different sizes/ratio? I sometimes have issues with my old cintiq and my laptop screen confusing windows and resulting in weird interface behaviour

Is your Windows up to date? Could you perhaps try running SP as administrator?
Valeria Gerontopoulos
Product Designer | 3D Artist


Sorry for the late reply.

I have double screen set-up, both same brand, size and model. So there's no issues with hardware.

I've tried the same thing on my gaming laptop. I have the same problem, I can't move layers, and do everything the correct way, as you can see in the video I shared earlier.

My Windows is up to date, so is all my Substance Suite.

So, no hardware issues, no version problem, not due to only one project, but to all old and new projects I create.

I can't work. I literally can't get things done because I can't manipulate my layers. I dropped my personal projects since nothing works.

PS: ran SUbstance as admin and changed nothing.


Sorry it took a while to get back to you, I was out of office last week.

I've managed to reproduce the issue. The bug comes from clicking on the thumbnail (and not the layer), as well as the fact that the layer you want to drag is not currently selected. I've submitted it to our developers. As a workaround, click within the area in the rest of the layer and/or select the layer before dragging it.

Thanks for bringing it to our attention :)
Valeria Gerontopoulos
Product Designer | 3D Artist

Finally! That works fine.

Thanks Valeria! :)