Author Topic: Exporting maps error  (Read 2418 times)

After exported main maps, I have this bug. It looks like metalness map was wrong exported. How to fix this bug ?

1,2 - marmoset
3,4 - painter



And another, when I export specular, it looks like as if painter wrongly addresses materials value.

Can you post the textures exported from Painter so that we can check what's wrong with them ? Thanks.

ok,
colour, metalness, roughness:

diffuse, spec, gloss:


and another, why when I export metalness as png/ tiff, it looks like this, but doesn't contain any alpha channel ?:

Sorry for taking such a long time to get back to you.

  • Regarding the spec/gloss export error : would it be possible to share the Painter project files with us ?
  • Regarding the png/tiff issue, I've been told this is the expected behavior from Photoshop : it does not create a separate alpha channel when opening png or tiff files but displays alpha as transparency. You can then extract it through "Layer->LayerMask->From Transparency".
Last Edit: November 03, 2014, 07:05:14 pm

pm send

Hi,

I might be off base to the problem you are having, but you can get rid of the alpha issue if you create a base layer and then add your paint layers on top. For example, create a fill layer that sets the specular to black or a base value. At this point, you have filled the texture with a base value. Then you can paint onto of this base and when you export, you won't have to worry about alpha.

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja