Author Topic: Dynamic Substance Materials not working as described in docs  (Read 8179 times)

After struggling for many days on this, I am desperate for answers and out of ideas (and I tried a LOT of variations with zero success).

I am trying to loop through a few `Static Mesh Components`, assigning each their own `Material Instance Dynamic` using a duplicated `Substance Graph Instance`

The blueprint below results in all three meshes getting the same material output (the last one set).  All meshes are obviously sharing the same `Substance Graph Instance` somehow despite clearly creating new ones and configuring the outputs "properly" on each iteration.

My substance factory is set to load synchronously, as you can see here:

Out of curiosity, I tried manually copy-and-pasting the graph instances in the content browser and explicitly setting them in the blueprint on each iteration. Doing this, everything works perfectly. All three meshes get their individual material outputs.

Please tell me someone has encountered this issue and can shed some light for me.

After more troubleshooting, I have some new information.

It seems that `Enable Instance Outputs` does NOT enable the outputs.  I have to manually check the box for the duplicated instance graph. Only then are the texture created so then I can manually assign them to the mesh. There is zero information of documentation on this method except for the changelog I found when it was announced to replace the legacy method `Generate Outputs`.  How can these output be enabled??