Author Topic: Substance Designer 4.5 Freezing Every Time Mac  (Read 1739 times)

Here is my mac details:

Software  Mac OS X Lion 10.7.5 (11G63)
Processor  2.7 GHz Intel Core i5
Memory  4 GB 1333 MHz DDR3
Graphics  AMD Radeon HD 6770M 512 MB

Basically I was making really good progress learning how to use substance designer. I had made quite a few substances. I was really getting into this software.

Then I clicked on materials in the 3D view window and I think I clicked PBR shaders although I can't precisely remember.

Now every time I even open a new package/graph I get the swirling cursor and it just freezes on me. I can see it's something gone wrong with the 3D view because it seems very slow to load up. :'(

I tried deleting it from applications and re-installing and the problem continued.

I even tried deleting my config files from the application support folder and still the problem continues.

What do I do next? I am at a loss..... :o

Last Edit: October 29, 2014, 02:23:41 pm

Ok, I waited and waited for it to catch up and I changed the shader to "blinn" and then exited and it stopped it freezing.

But now I can't see any of my work rendered in either 2d or 3d - what do I change the material shader to in order to get it back to how it was?

Quote
what do I change the material shader to in order to get it back to how it was?
In the 3D view, open the "Scene" menu and select "Reset All".

Maybe you can try to reduce a bit the requirements of the PBR shaders by opening the "Tool->Preferences..." menu, and select the "3D View" tab.
I would suggest first trying to disable the post process and check if that improves performance.
Then you can also reduce the "Sample Table Size" parameter which controls the quality of the PBR specular reflections (default is 40, you can try to reduce it to something like 16).
Also reducing the "Max Texture Size" to 2K may help as your graphics card is rather limited in memory.

Thanks that is quite helpful actually. Currently drooling at the new imacs......must....wait.....for better.......longer.....