Author Topic: Cinema 4D R20 Invalid Substance Asset file  (Read 15074 times)

I'm still new to Substance and today I've tried to import a Substance Painter 2018.3.3 via pipeline > substance engine.

I keep getting the same error when trying to import newly created .spp files
"Invalid Substance Asset file"

Cinema Version is R20.059

Is this a known issue or am I doing something wrong?

an .spp file is not a Substance Material file.  It is a document from Substance Painter.  They are useful for when you need to take a break from painting and come back to the file later to finish up.

To bring your painting and material work into C4D, you need to export your maps from Painter using the file--> export feature.  You shouldn't need to export the mesh.  Just the maps as I assume the mesh is already exported somewhere else since you were able to paint on it.

C4D r22 (Mac) seems to have fixed the Invalid Substance Asset File errors for 'valid' sbsar files. R21 gave me the Invalid error for numerous Substance Source sbsar files and all the decal sbsar files I tried to load. No such errors in r22 (Mac).

Same issue on R21 WIn 10. I am trying this for the first time (and just purchased credits). The 2nd material I chose has this issue (Burnt Metal).

Any tips?