Author Topic: SD Crashes every time I start a new substance.  (Read 5630 times)


Basically the same as what the title says. Every time I launch the program and click the button to make a new substance, the programs crashes/locks up. In order to get it to work I have to uninstall and reinstall the program. It only works the first time I press the button to create a new substance, after that it crashes/locks up every time until I uninstall/reinstall again.

Anyone experience this or know why?


I think I already answered you via our bug report system but it can be useful for other users.
The problem comes from outdated graphic card driver.
An update of the driver should fix this problem.
QA Analyst

I updated my graphics drivers. I'm currently still having the issue. Is there anything else? I uploaded the log.

I tried uninstalling and reinstalling once again and it was still doing the same thing.

I’ve solved a similar problem by deleting the application preferences.  Was this one of the things you tried?

Tried deleting preferences and it didn't work.

It's been over a week and it's still not working. I'm going to try and redo my entire OS and hopefully that works.


Sorry for the late answer.
We know we have an issue with some specific set up in 3D view.
Can you go into this folder : C:\Users\USER_NAME\AppData\Local\Allegorithmic\Substance Designer  and check if you have the file named : user_view3d_settings.sbsscn
If yes, cut and paste it in another folder than this one.
Now try to launch Designer. Do you still have a crash ?

Thanks !
QA Analyst

I ended up reinstalling my OS to get it to work. It did end up working afterwards. Not sure what would have caused it. An unofficial fix but a fix nonetheless. I'll bookmark this page and if it happens again I'll do what you said and see if it works. If it does I'll update this.