Author Topic: ERROR Could not find vertex colors in mesh  (Read 605 times)

Hello everyone
i was trying to bake normal map from a high poly mesh to low poly earlier this morning. However this error pops up everytime i tries baking and the normal map is always pale blue after baking.
The Log shows something like this :
[Baking] Could not find vertex colors in mesh Upper_Body.001_Plane.003
[Baking] Could not find vertex colors in mesh Upper_Body.001_Plane.003
[Baking] Not enough data in the high poly to use selected baker. Baking has been canceled.

Log image as below

My model is from blender and i dont think theres something called vertex color in the program. Also i dont remember theres a mesh called Upper_Body.001_Plane.003 in my model file. I have been looking for this name for hours but still clueless.

I have read other discussions already and i already assigned materials to both my high and low poly mesh and also UV unwrapped them both, Normals are also facing outside.
Please help.

If you don't need a color ID map, you can uncheck that in the baking window. This will get rid of the error message.

Just a note for the future; you don't need to assign materials or unwrap the high-poly model. :) Unless you use the materials to bake a color ID.

Thanks for the tip Ola, the error message disappeared as i stopped baking the ID map, however the normal still didnt change after i baked them. Now the problem is surly not the vertex colors but something else. Now theres no error messages but the normal remains after the same after baking.

Can you verify that the low and highpoly mesh overlap? If there's a mismatch, the normal will be wrong as well.

I found what was going wrong! i didn't check the compute tangent space per fragment in the project settings. Now i can bake normals finally. Thanks for the help OlaHaldor

Ahm nvm it doesnt work when i check or uncheck the box now, well crap. anyways the meshes are overlapping i am certain about that

Alright i feel like a dumbass now, i was looking into the bake mesh map settings and unchecked the use low poly as high poly mesh box, and it finally works i mean it finally does. i really feel like a retarded now oh god.
anyway thanks for your help OlaHaldor