Author Topic: Batch export always export at 4096  (Read 392 times)

I've reopened an old graph with a substance designer with the idea of exporting the base color at 8k resolution.
I do this very often and it works fine every time, except for 1 material.
I have a material that, no matter what resolution I choose in the Batch command in substance designer it always export at 4k

To be more clear, it seems to export in 4k olny when setting the Batch export size beteween 1024 and 8192, if you try to export at 512 it does it correctly and i assume it's able to export the correct size even when using smalle sizes

Hello,

Thank you for reaching out to us, and providing your graph.

We were able to identify the cause of the problem. It appears a 'Safe Transform Grayscale' Output Size is set to 'Absolute' 4K.





This node being relatively early in the graph and broadly distributed, most of the nodes inherit its Output Size. Setting the Output Size of this node back to 'Relative to Parent' should solve the issue.

For your information, the 'Output Size' parameter should be set as 'Relative to parent' as much as possible, as per our Performance Optimization Guidelines.

Feel free to get back to us if you need further assistance.

Best regards,
Luca Giarrizzo
QA Analyst
Substance Designer Team

Thanks for the answer! i always forgot to reply but i found that almost right after the post, and managed to fix that.
as for the optimization guidelines i familiarized myself with them and this was mostly a very complex graph to be used for some experiments/stress test, we are figuring out what hardware will be best to bake a large number of High resolution textures with designer