Author Topic: UE 4.22.2 + Plugin 4.22.0.33: Stuck in Substance Source Loading Screen  (Read 60717 times)

Hello,

With UE 4.21.2 the Substance Plugin works fine for us.

But with a simple blank Blueprint test scene in UE 4.22.2 with the newest plugin Substance 4.22.0.33 the Source screen is stuck on loading.



When looking at the logs I see the following after loading the project:

LogSubstanceCoreModule: Substance [CPU] Engine Loaded, Max Texture Size = 2048
LogSubstanceLiveLink: Warning: Unable to send data along socket, closing connection


The line "Unable to send data along socket, closing connection" sounds bad, but in UE 4.21.2 with the Substance Plugin I get the same warning and the plugin works, so this can not be the problem.
 
If I then click on "Source" the plugin tries to load the DB, but then is stuck in the loading screen:

LogSubstanceSource: Loading Substance Source Database

If I now close the project the UE Editor closes, but the Editor is still open in a Background Task and I have to close the task manually:




Any help would be more than welcome. :-)

Best
Andreas

Last Edit: June 13, 2019, 09:36:39 am

I'm having the same problem... Eternal loading screen. Any update on the matter?

Same problem for me! Stuck at loading screen.  :(

Hey, support team... No response yet? It's been almost 2 weeks since the first post!

The problem persists with UE 4.22.3, no changes.

I just re-tested by creating a new UE 4.22.3 project (Blueprint, blank, no starter content) and the I switched on the plugin v4.22.0.33 and restarted the UE Editor.

Result: When I click on the Source-button the "Substance Source" tab opens and the loading screen appears, and stays for minutes, hours, ...

When I now close UE I have to go to the Task Manager and remove Unreal Editor from the background processes, it doesn't close correctly on it's own because of the Substance plugin.

Please fix this, because of this we cannot use Substance materials in our 4.22 projects.

Best
Andreas


Still waiting since a month and using other alternatives... Planning stop using Substance and cancel my subscription :(

Hello Everyone,

I greatly apologize for the lack of response and such a long delay in a reply.

It looks like there was an API update for Source and this caused an issue with the plugin. That issue has been resolved on the Source side and Source should now be loading in UE4. I tested UE4.22.3 and it was working. Please let me know if you have any issues.

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

I am still having an issue - Source plugin wheel spinning....

I am still having an issue - Source plugin wheel spinning....

Hi,

Which version of UE4 and the plugin are you using?

Cheers,
Wes
Integrations Product Manager / Training
wes.mcdermott@allegorithmic.com
Twitter: The3DNinja

Hi

I got the same problem...

My version is 4.22.3. The same wheel spinning all the time

Thank you for your attention

I am experiencing the same issue as well.  I am also using 4.22.3.

Please advise.

Thanks.

Kurt

Sorry Wes.
But I’m working with 4.22.3 and I’m having the same problem. I’ve tried in 4.22.0, 4.22.2 and also in last version.

Hello Everyone,

I greatly apologize for the lack of response and such a long delay in a reply.

It looks like there was an API update for Source and this caused an issue with the plugin. That issue has been resolved on the Source side and Source should now be loading in UE4. I tested UE4.22.3 and it was working. Please let me know if you have any issues.

Cheers,
Wes

I'm also getting this problem. Please look in to this.

I decided to install 4.21 to confirm that it was working. It is working correctly in 4.21. Just not in 4.22.

Anyone found any solution to this problem? Having the same issue.