Author Topic: [SOLVED] Substance Designer baker bakes black AO  (Read 181 times)

Hello,
i upgraded substance to the newest version and since this update Designer bakes totally black Ambient Occlusion and Bent map while Albedo, Normal map and the height maps are fine. Any ideas what happened?
The substance designer version I use now is 2019.1.1.
I have NVidia Graphics car with drivers updated.
I bake with default settings. Screenshots attached.
Any ideas, fixes or workarounds .. others to use Knald, XNormal or revert SD to previous version?
Thanks in advance,
G.
Last Edit: June 03, 2019, 10:12:07 am

You mentioned it's not working since 2019.1.1, had you ever baked AO for this exact geometry and settings, with the prior version of Designer?

Regardless, here's a few suggestions:
  • Your normal Y could be flipped on the mesh, depending on which DCC it was exported from. Try changing the "Normal Orientation" parameter to "OpenGL".
  • Check if your normals are accidentally inverted.
  • Check if your bounding boxes are correct.
  • Try disabling the "Relative to bounding box" parameter.
  • Check if your UV set 0 contains data.
  • Try baking without the HD mesh. (Enable "Use low as high definition" checkbox). Still black?


As I see now AO is being baked as a white map.. .. I started test from ur 6th step :).. during baking I was able to see weird checker.. shot included ..and it turns white after that second. With every change I can render albedo properly.. shot included. This time to save some time I was baking in 2048x2048 without anti alsiasing

1 Your normal Y could be flipped on the mesh, depending on which DCC it was exported from. Try changing the "Normal  Orientation" parameter to "OpenGL".~
- white.. nothing changes
2 Check if your normals are accidentally inverted.
- checked.. its ok. Otherwise I wouldnt get also albedo, normalmap and the height map
3 Check if your bounding boxes are correct.
- it has to be correct - its something very similar to this one (https://www.artstation.com/artwork/xz2yD4)
as I understand setting it to 0.3 means it generates bounding box of 30% of lowpoly model size.. is this correct?
If this settting wouldnt be correct albedo or notmal map wouldnt be baked as they are. Am I right?
4 Try disabling the "Relative to bounding box" parameter.
- it bakes white ambient occlusion but correct albedo
5 Check if your UV set 0 contains data.
- it does. otherwise it wouldnt bake albedo, normal and height map correctly
6 Try baking without the HD mesh. (Enable "Use low as high definition" checkbox). Still black?
 -White (lowpoly model was a flat plane - like this one: https://www.artstation.com/artwork/xz2yD4)

I decided to rebake something I already baked before. I picked this one:
https://www.artstation.com/artwork/yb2zmK
I have noticed that time to load highpoly model was much longer compared to the last one.. which is weird as both highpoly models have exactly 67mln poly .. but unfortunately it wasnt an issue anyway since.. the albedo was baked properly and AO is still baked as pure white now. Dunno why white.
So.. lowpoly I used is ok in 100% since I already baked it and it worked
Highpoly is 100% correct as I baked from it already and it worked

I restarted Substance Designer and tried again with the one which waworkigng before (sand) and AO is being baked i 0secs into black again.

If this helps, my current config:
Windows10 64 bits
i7-7700K Cpu 4.20GHz
64GB of RAM 2666MHz
GForce GTX 1080Ti 11GB RAM  (drivers: 417.35)

At least you've confirmed that it's affecting old assets as well.

Out of curiosity, can you try baking Thickness from Mesh as well? I have a hunch it's going to fail too.



Substance 2019.1 went through some major changes for bakers, and 2 of the three bakers affected by these are currently not working for you.

It might be more than just a coincidence and you could be experiencing a driver conflict.
You mentioned originally that your drivers were the latest, however your last post says they're 417.35.

For some of these features, with your hardware configuration has specific requirements regarding RTX/Optix:
Quote
To access the feature, make sure to update to the following drivers :

    Nvidia 10XX and 20XX GPUs : drivers 430.39(compatible with both DXR and Optix)
    Nvidia 9XX and older : drivers 419.67 or 430.39 (drivers 425.31 have an issue with Optix)

Note that DXR is also available on GeForce GTX 10xx GPUs (with up to date drivers). DXR also requires Windows to be up to date for working, see this page for more information.

Check out the "Support of Optix in Bakers" section of the release notes:
https://docs.substance3d.com/sddoc/version-2019-1-180191970.html

You can also try to disable the RTX/Optix settings in preferences and see if it makes a difference first.


Hey,
yeah, thickness was black too.. screenshot attached.

After I disabled the RTX/Optix both maps bakes properly.. ao and thickness

re:
...however your last post says they're 417.35.

Sorry, my bad. Yeah, I was using the latest available driver..it is: 430.86. It was the first thing I updated after I struggled with results.

I assume I should keep 'RTX/Optix' disabled by default then or upgrade the graphics card :).

Shouldnt the Substance detect the graphics card and switch it off automatically if it cant perform any bakes for AO, thickness and bent normal? Or is it just my config. I believe there is a lot of ppl without newest graphics card.

Thanks for your help,
Grzegorz

After I disabled the RTX/Optix both maps bakes properly.. ao and thickness
That's awesome; I'm glad you got it working now.

I assume I should keep 'RTX/Optix' disabled by default then or upgrade the graphics card :).

Shouldnt the Substance detect the graphics card and switch it off automatically if it cant perform any bakes for AO, thickness and bent normal? Or is it just my config. I believe there is a lot of ppl without newest graphics card.

It shouldn't turn it off because your hardware and drivers are fully compliant with the requirements (not that it's designed to turn it off DXR/Optix anyways).
Both 9x and 10x series cards should be DXR compliant on Windows 10, if I'm not mistaken.

It sounds more like a bug to me.
You should reach out to the developers with a bug report about your findings.

Hello Grzegorz,

Thank you for reaching out to us with this issue, and thank you to NevTD for being so helpful!

Another user was having issues with Optix, and the details we provided might be relevant here as well. Here is the thrad.

Additionally, please note the DXR backend is available from the Pascal GPU architecture (i.e. GTX 10xx/16xx) and above only.
It is emulated on Pascal - at a significant performance cost - and natively run on Turing (i.e. RTX 20xx) with RT cores. DXR is also only available on Windows version 1809 and above.

Best regards,
Luca Giarrizzo
Last Edit: June 03, 2019, 10:20:33 am
QA Analyst
Substance Designer Team