Author Topic: [SOLVED]Substance Designer on Ubuntu  (Read 1292 times)

I know that its not official supported but I'm installed Substance Designer, Painter and Alchemist with this method:
https://ycnrg.org/substance-on-ubuntu/

Painter and Alchemist runs, but Designer doesnt open. I figured out that the Designer executable its interpreted as a Shared Library instead of a normal executable. Anyone knows how to fix this? I'm on Ubuntu 19.04
Last Edit: June 06, 2019, 12:14:55 pm

Ok, I got this if I run it in Terminal:

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: minimal, offscreen, xcb.

Hi kikepgomez,

Here is another thread discussing the problem you encounter: https://forum.substance3d.com/index.php/topic,29285.0.html . Could you try the workaround I proposed at the end of this thread, namely removing the file libfreetype.so.6 from the install directory of Substance Designer?

Works perfect, thanks!