Author Topic: High DPI on 4k monitors looks strange  (Read 4822 times)

Hello

I recently updated to 2.1 and my icons and text are all really big and being cut off in certain sections. It just feels too large, like I'm suddenly old and need everything really big :) It's especially noticeable on the tabs

Also disable display scaling option for windows doesn't seem to have an effect at all

I've included dxdiag and sp log

This is what it looks like


This is what Substance Painter should look like on a 4k screen with the proper scaling. That's also the scale you should get on a regular 1080p monitor, I don't see anything wrong in your screenshot.
Where do you see icons being cut-off?

Well dang the whole point of a 4k monitor is the extra screen real estate beyond a 1080p monitor that's why it's a 4k monitor. If I wanted things to look the same as 1080p I'd stay on 1080p. Everything is excessively large compared to the previous version and there is no effect with the disable display scaling.

I used to be able to get 15-20 layers in there now I can only get max of 12 also the tabs at the bottom Texture set settings Display Settings and Viewer settings are all cut off

Also the layer names are cut off on the bottom there are many many things that look like they are considerably larger than they're supposed to be. On a 4k monitor I don't need the text to be 18px

I would at least like the option for display scaling to turn off this new "feature" if possible I liked the extra screen real estate and smaller icons and text


This is an example of how it should work


1080p Rez


4k rez


Look at all that glorious room and extra resolution. That's what I paid for with a 4k monitor so to have it be all gone and be intended doesn't seem correct.

On most 4k monitors, laptops for example and even medium sized monitors (22"), your Modo example with the default font and icon sizes is totally unusable because everything is much too small, that's why we introduced this scaling. I'll talk with the team and see if we can have an option to deactivate scaling on 4k monitors (like it was before 2.1).
Last Edit: June 03, 2016, 09:03:03 am

You have actually two solutions if the scaling doesn't work for you :

- Disable DPI virtualization for the application. To do this, right-click the application’s shortcut and then click Properties. On the Compatibility tab, select Disable Display Scaling On High DPI Settings, and then click OK. This causes the text in the application to appear clearer. However, if the application does not correctly handle high DPI settings, this procedure may have adverse side effects such as truncated text and incorrectly sized graphical elements.

or

- Lower the overall Windows DPI setting. To do this, open the Display item in Control Panel (or search for "dpiscaling" from the Start screen), and then adjust the slider under Change the size of all items. You may have to click to select the check box for Let me choose one scaling level for all my displays and then change the scale to 100 percent.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Thanks for the tips, but as I mentioned the disable display scaling button in Windows has 0 effect on substance painter. So that was really the biggest issue.

Thanks for the tips, but as I mentioned the disable display scaling button in Windows has 0 effect on substance painter. So that was really the biggest issue.

Okay, noted. What is your scaling set too ?
I tried to reproduce your problem but wasn't able to currently, if you can describe a bit more your windows setup that would help us a lot.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.




I'm also have problems with new DPI UI scaling. It seems doesn't work with 125% scale (win7 x64 sp1 2560x1440) :( . Other programs works as expected with 125% as example 3dsmax.
Royal Ghost | veda3d.com

Indeed, that's something we noticed too: intermediate scaling seems to not have any effect in Painter. 50% step should work however (100%, 150%, 200%, etc.).
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Indeed, that's something we noticed too: intermediate scaling seems to not have any effect in Painter. 50% step should work however (100%, 150%, 200%, etc.).

Will be it fixed in future updates? (2.1.1 still don't work)
Royal Ghost | veda3d.com

Will be it fixed in future updates? (2.1.1 still don't work)
This is a limitation of our UI framework, so unless they start supporting it, we won't have this feature.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

The 4k scaling of substance is still much too big.
And when I go to properties and scale it to 150% by system ("recommended") it is much too small.

And scaling higher (like 200%) isn't good, because this affects all other proper designed applications, too.

Please add a resolution feature to be able to customize substance at least in 50% steps.

Thanks!
Last Edit: May 26, 2019, 06:04:01 pm