Author Topic: Height no longer appearing in 3d view  (Read 2106 times)

While working through the "Substance Designer: Creating your First" tutorial, the height for my substance in the 3D view suddenly vanished on me and I cannot for the life of me figure out how to get it back. Please, send help. I'm desperate y'all.


You should create output nodes in your graph, you can do that quickly by right clicking on the "base material" node and selecting Create/ Output nodes (when it asks if you want to create nodes for hidden connectors, select "No").

- Then Right click in the graph and select "View outputs in 3d view".
- Make sure you also use the Tesselation shader in the 3D View: Materials / Default / Definitions / physically_metallic_roughness / Tesselation.
- And finally adjust the displacement intensity in the shader parameters: Materials / Default / Edit : Adjust the "Height Scale" value.
Product Manager - Allegorithmic

You should create output nodes in your graph, you can do that quickly by right clicking on the "base material" node and selecting Create/ Output nodes (when it asks if you want to create nodes for hidden connectors, select "No").

- Then Right click in the graph and select "View outputs in 3d view".
- Make sure you also use the Tesselation shader in the 3D View: Materials / Default / Definitions / physically_metallic_roughness / Tesselation.
- And finally adjust the displacement intensity in the shader parameters: Materials / Default / Edit : Adjust the "Height Scale" value.

The last step did the trick. It was already working before, so I can't imagine why things changed on me, but it's all good again. Cheers!

The 3D View settings get reset at each session, if you wish to save the state as default you have to do that explicitly through the scene menu.
Product Manager - Allegorithmic

Hi Nicolas,

What do you mean by this?
Quote
do that explicitly through the scene menu.

Where can I find this setting?

Thanks,
Miklos