Author Topic: Specular workflow using non pbr spec gloss. opacity is set to cutout only???  (Read 3418 times)

At work we're working on an old project that is a specular workflow. we're using the non pbr spec gloss material (only material in SP we could get spec results with) one of our artist today had to paint opacity on their texture and it's only doing CUTOUT opacity?

...we're totally boned atm. Can someone enlighten me to how we get clean opacity using a spec workflow in SP? We're really screwed atm and these forums are my only hope. Really, really would appreciate any info on this...I'm dying to get help on this actually.


Here is a shader for non-pbr spec gloss that support transparency.

Thank you jeremie. Can we maybe have this included with SP for the future? Transparency is totally legit and cutout doesn't give the results i think most artists would be after.

Here is a shader for non-pbr spec gloss that support transparency.

Hello Jeremie,

I've tried this shader in the version 2018.3.2, and I got a compilation error when I tried to select it.  Is this still compatible with the current version of SP?  I was simply adding this to shelf manually, but is there anything special I need to do to make it work?  I'm still new to SP, and I'd appreciate your help with this.

[ResourceShader] ----- FS compile log -----
[ResourceShader] File index:
    0: shader-skeleton.frag.glsl
    1: shader-extensions.frag.glsl
    2: shader-common.frag.glsl
    3: lib-sparse.glsl
    4: lib-utils.glsl
    5: lib-bayer.glsl
    6: non-pbr-spec-gloss_alpha-blending
    7: lib-alpha.glsl
    8: lib-sampler.glsl
    9: lib-defines.glsl
    10: lib-random.glsl
    11: lib-emissive.glsl
    12: lib-env.glsl
    13: lib-vectors.glsl
    14: lib-normal.glsl
[ResourceShader] Fragment shader failed to compile with the following errors:
[ResourceShader] non-pbr-spec-gloss_alpha-blending:89 | ERROR: 6:89: error(#202) No matching overloaded function found: getOpacity
[ResourceShader] ERROR: error(#273) 1 compilation errors.  No code generated
[ResourceShader] --- FS compile log END ---

Indeed, this version was deprecated.
Here is an updated one.

Thank you very much for your help with this, Jeremie.  It works great.  :-)