Author Topic: Update (2018.1.0) - Lighting/Material View Doesn't Work  (Read 4935 times)

Hi, unfortunately, the issue hasn't been solved yet, we'll make sure to update this thread as soon as there is news.

... dissapointing! Well old version started not working too after upgrading Sierra  ... 
I am paying for a software which I cannot use right now ... And wondering ...

What Nvidia (CUDA) card compatible wiith OS 10.12+ Default drivers at ≥ 4GB that will work with Painter does Allegorithmic recommend?

Designer has the same issue by the way !

I have exactly the same question and can't get an answer. I need a new card but can't figure out which will be compatible with Substance. I thought maybe a Quadro K5000 but found elsewhere on the forums that Quadro and CrossFire cards are not recommended as they are designed more for CAD vs game engine/texturing, etc. I've already returned a GTX 1080Ti after discovering that simply opening SP would reboot my system every time, though all other apps (Maya, etc) worked fine.

Are people using GTX 980s but on older version of SP?

Hey there, what a shame that you didnt figure this out yet.

Right now my work around is to use SP 2017 on macOs Sierra with a 980 card. Everything works with the nvidia driver except for baking the maps. For this i have to boot into windows, do the bake and import the maps in macOs. I could also switch to de mac default driver and do the bake. But i think this uses even more time than booting into windows.

I really hope you guys get this done. - No problems in any other program. (Adobe, Blender, zBrush, Maxon) I really dont wanna change to an other piece of software for texturing.

Best regards
Last Edit: August 07, 2018, 09:18:44 am

Hi, i found that deleting the plists under ~/library/preferences/com.allegorithmic.[other stuff].plist fixes my issue of a black viewport when loading a project or .fbx and the tons of crashes i was suffering from. i hope this helps anyone checking this thread out. To the SP devs i sincerely hope this helps you guys out figuring out a potential fix and helps in you guys deciding to support unofficial mac gear sooner as well.

In case it helps, this is my hardware:
CPU: Intel I7 8700 3.2Ghz
GPU: Gigabyte GTX 1070 G1 gaming
Ram: 16GB 2666mHz ddr4 ram
Display: 1920X1080 144hz Acer
SSD: Samsung NVMe 960 EVO 256GB
Harddrive: 1TB sata3 7600RPM
OS: MacOS High Sierra 10.13.6
Last Edit: September 12, 2018, 06:01:19 pm

Hi, i found that deleting the plists under ~/library/preferences/com.allegorithmic.[other stuff].plist fixes my issue of a black viewport when loading a project or .fbx and the tons of crashes i was suffering from. i hope this helps anyone checking this thread out. To the SP devs i sincerely hope this helps you guys out figuring out a potential fix and helps in you guys deciding to support unofficial mac gear sooner as well.

In case it helps, this is my hardware:
CPU: Intel I7 8700 3.2Ghz
GPU: Gigabyte GTX 1070 G1 gaming
Ram: 16GB 2666mHz ddr4 ram
Display: 1920X1080 144hz Acer
SSD: Samsung NVMe 960 EVO 256GB
Harddrive: 1TB sata3 7600RPM
OS: MacOS High Sierra 10.13.6

I'm not sure we will be able to support unofficial hardware anytime soon, however it's good to know there is a potential workaround available meanwhile. I will document it.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

well Substance Designer working (viewport + iRay) 
but Painter still has the same issue ... iRay not working too ... :/

Seven months since my initial post, and it's gotten worse. Now it won't show my model at all. Blender does great, and it's free.

Hi there! i resume this post just to notify that i recently update my OS and driver!
Now on my MAC with HI SIERRA and 980ti with this driver/cuda configuration: driver 387.10.10.10.40.113 Cuda 396.148 Substance Painter 2018.3.0-2570 works very very fine! no issue as a precedent Os or driver.

But Attention! i have update the cuda driver today with the last version and SP not work! i have a total black screen in the wiewport (no interface, just woewport)! so i do a step back on previous cuda...

hope this can help someone!

Paolo

Anyone hear of progress from Allegorithmic with the Mac Pro towers and the non Mac GPU's? 2017.3.3 is the only version that will work for me.