Author Topic: Publishing errors  (Read 6213 times)

Hey there

A disclaimer first: I'm pretty new to Substance designer so I apologize if this is a silly question with an easy fix.

I'm using build 3.2.0 11232 trial version.

I made a substance that I now want to test out in 3DS Max. But when I tried to publish it, I got the following error:

It's obviously three instances of the same thing.
At first I figured I messed something up because three exclusion blend nodes I have in there, use a subgraph for one of their inputs. So I deleted the exclusion nodes and tried again.

Then I got this

After reading the first message more carefully I saw that the error is basically a missing mask input in the exclusion node. I placed a uniform white color there. Tried again. Got the error number two again.

I read somewhere that maximum map when cooking the outputs is 2048. I found that odd, especially since I edited the preferences and increased max cooking size to 32768. Reduced everything to 2k, and tried again. Error number two again.

So there are two problems here.
1) The exclusion blend node breaks at publish if there's no mask input
2) I have no idea what that is :)

I would really appreciate any help/info you guys can offer.
This is a great tool, but the errors I get render it pretty much useless at the moment. It would suck if I was unable to use it because of this.

Look forward to your (hopefully fast) reply, I'm eager to continue discovering the magic that is Substance Designer :)

The warnings in the first screenshot should not have prevented you from cooking. The error in the second screenshot probably means there is a dependency missing or something like this. Could you pack the substance and its resource folder and send it to us by email ? I'll try to see if I can pinpoint the error origin.

I've sent an email containing all the necessary files via contact support link.
Hope you'll be able to find what's causing the issue.

Thanks for the quick reply, and hope to hear from you soon.

It seems we didn't receive your mail.
Could you post your graph on this forum directly please?

Head of Product Management

Hmmm, I got the automated email reply about receiving my mail

But anyways, over the weekend I checked, double checked, deleted, linked and re-linked all of the external files to make sure everything is in order on that end.

Oddly enough, error doesn't seem have anything to do with nodes or improper resource linkage.

Things work fine up to (and including) 1k texture size. When I set the output size to anything above 1024, publishing fails with the error from second screenshot. As I said before: preferences are set so maximum cooking size is 32768, so I'm not sure what else I can do...

Here are the links to my packages
First is "edge scratches" thingie that I use in the second graph. Not sure if that's required for your test, but I guess it won't hurt.


MainSubstance  (the one that won't publish)

Incidentally, is there a way to test or verify that all nodes/files are properly linked?
Like a tool or a dialog that shows you problematic dependencies. I did it all manually. Meaning that I clicked every bitmap node and checked that it has a valid link to corresponding resource. It would be cool to have them all pointed out to me in some manner.

If you guys could just send me an email or PM to let me know you got the files, just so I can stop obsessing over it, that would be awesome :)
Last Edit: February 05, 2013, 03:40:57 am

Issue has been solved via PM.
For others who might run into the same issue, always publish your substances with your graph resolution either set to an absolute resolution or with the default "Parent x1" setting if using Relative to Parent size.
This will ensure good compatibility of your assets with all the substance-enabled software out there.