Author Topic: Substance Painter 2020.2 Linux Not Starting  (Read 275 times)

Hi

We have installed Substance Painter 2020.2.0 rpm on a linux machine and it didn't through up any errors but it won't start, we get the splash screen but then it crashes out (2020.1.1 works fine).
This is the message that appears in the terminal when I try starting in the commandline:

terminate called after throwing an instance of 'boost::wrapexcept<boost::uuids::entropy_error>'
  what():  getrandom
Abort

I thought that there may be a library problem but if I run "ldd Substance\ Painter" everything looks fine.

We are running CentOS 7.3 which is a little old but it's the qualified kernel that is recommended for the version of maya that we are using.

Would someone be able to point me in the right direction?

Thanks

Dan
Last Edit: July 27, 2020, 09:35:26 am

Thank you.
We are working on it it will be fixed in the next minor release 2020.2.1 (6.2.1).

Okay, thank you for the update.

Dan

Hi Dan,

We just released the HotFix 20.2.1 (6.2.1) with the fix for your problem:

[Linux] Crash after the splash screen on CentOS 7.3

If you try it, could you let us know if it fixes the issue ?

Hi Cedric

I have just tried the HotFix and that seems to work, the software no longer crashes after the splash screen.

Thanks for your help.

Dan