Author Topic: Baker tiles rendered result by multiples of 1024  (Read 126 times)

Hi!

I'm new to Substance Desinger and Painter, and quite enjoying it so far. I'm working through a tutorial series by Glass Hand Studios to learn Substance Designer and Painter with a model I downloaded from them. I'm running into an issue when I try to "Bake model information". The rendering looks like it's going fine, but then the final result is always a tiled black and gray version, the number of tiles being a multiple of 1024. That is, if I try to render at 4096, I get 4x4 tiles. If I try 2048, I get 2.2 tiles. Even weirder, when I try 1024, I get a flat gray image with no information. I'm including screen shots of the process, as well as the result.

I have tried the same procedure on several other models (including a stripped down "Henry" that comes with C4D R18 content browser). Same result.

Any help would be appreciated. Being a noob, I'm wondering if I'm doing something wrong, but at this point, I think it might be a bug.

Thanks,
- Greg Reynard

Here are some screen shots. Note: The screen shots are of the baker window, but I can confirm that the result files looks the same, minus the red UV lines, of course:

AO during the render:


AO result, 4096:




AO result, 2048:



AO result, 1024:


Position result, 4096:

Hi,

Apparently you have a Geforce 980 Ti inside a Mac Pro, is this an official configuration?
I'm asking because the log indicates there are issues related to the drivers that may explain the problem you are describing.
Product Manager - Allegorithmic

Ah, fair point. I hadn't thought of that. It is not an official configuration. I'm a freelance motion graphics animator, and 95% of my gigs are in a studio, working on someone else's computer. I put together the Mac Pro 5,1 / 980Ti rig for home mostly as an inexpensive (my buddy was selling his 980Ti's for a good price) way to teach myself new stuff... like Octane, Redshift, Cycles, and Substance. Honestly, it's been remarkably stable, given that it's non-standard and using an nVidia driver that wasn't actually written for it. Yesterday for the first time I got a black screen crash and had to hard reboot, and that was while I was running Substance Designer. It's possible Substance isn't crazy about this setup.

The weird thing is that it looks like it's rendering the bakes just fine... but when it comes time to make the final image, that's where it fails. C'est la vie. It's not the end of the world, and hopefully I can still learn other parts of Substance just fine. Thanks for responding.

Cheers,
- Greg


I can only suggest you to try various driver versions and see if one fixes the problem.

We can't do support on non official configurations because if there is a problem like yours we can't have the exact same configuration on our side to reproduce and fix the problem (especially if the problem is on the driver side).
Product Manager - Allegorithmic

Yeah, I totally understand. No worries! In spite of this minor road bump, I'm really digging the process of learning Substance. Hopefully some of the places I work will have it installed on actual standard boxes... or at some point in the not too distant future I'll build myself a legit PC.

Cheers,
- Greg