Author Topic: [SOLVED] Inserting grayscale into blend warps data  (Read 737 times)

Good evening!

I'm new to Substance Designer, and I've come across what I believe is a small issue when I try to layer two grayscale maps over each other. When I insert my stones texture map into another blend node or anywhere else, the surface data becomes oddly warped around. At first, I thought one of my blurs were low quality causing some sort of error, but I've ruled that out and now I'm just simply confused.

I don't know what is causing the sudden change in data, but some insight would be very helpful and appreciated!
Last Edit: April 28, 2019, 08:33:49 pm

Hey, I took a look at your graph, but can't tell what the issue is.
Can you maybe take a screenshot to show what goes wrong?

Happily, sorry about that!

The first screenshot is what I would like the surface of the bricks to look like. It's soft, but kind of crumbly and it has some edges to it:

The second screenshot is what it looks like when I try to hook it up to any foreground in any blend node, even when the blend mode is set to Copy and is by itself. I also tried reducing the strength of the normal map thinking it might have to do something with the blend node, but it doesn't change. It looks like it's been sitting at the bottom of the Dead Sea for a thousand years:

This is what I would like my next move to be, granted the normal map is pretty insane right now. You can see the bricks are performing the second screenshot's action:

Hopefully this helps elaborate a bit!

is there a chance that any of your nodes involved in this is 8bit? can't tell from the screenshots

Divi.cig is right. There is a blend node in the 'ground test' frame that is set to 8 bit. (You can see L8 under the node)

When bitdepth is set to 'relative to input' nodes will 'inherit' the biidepth of the previous node. When a node has more than one input, like the blend node, it will inherit information from the input that has the little dot in it. When nothing is plugged in here, the node will default to using 8 bit.

That did the trick!

You guys are rock stars! Thank you for takin the time to help me look over it.