Author Topic: Issue with Default Cells Procedural  (Read 4775 times)

Hi! I'm very new to substance designer and I'm trying to redesign my workflow around it but I'm running into an issue right off the bat.

When I create a "Cells" procedural, any of them, there is an odd tiling/alpha issue. The only way to fix it that I've seen so far is by decreasing the distance but then the cells are far to large for I need.

Any recommendations or thoughts? I've attached a capture of the default cells right after creating it.

Can you tell us more about your configuration (Substance Designer version, OS, graphics card, graphics driver, etc.) ?

Substance Designer 3.5.2
Windows 7 64bit
Graphics Card: NVIDIA Quadro 5000
Driver: NVIDIA

Thanks. We had one report of that problem, but it was on a mac running an old version of OSX, and we never managed to reproduce the issue.
What's your CPU model/brand ?

Also, could you try to switch to the SSE2 engine (in Tools->Switch Engine...) and tell us if you still get the same result ?

I had the same results after switching to the SSE2 engine.

My CPUs are Intel Xeon E5-2650.

The problem seemed to correct itself for a little while after restarting my computer but it returned. Possible after it went to sleep. I'm not entirely sure.

The issue is still present after I restart. It's unfortunate because it is affecting a lot more now than the cells. Several of the default noises are doing similar things.

Ok, we may have found what's going on (but we are still unable to reproduce it). It seems to be a weird floating point rounding difference.

Could you test the attached substance and tell us whether it suffers from the same bug or not ? (hopefully not)
Last Edit: June 19, 2013, 06:03:15 pm

It appears to be correct when I open it with Substance Player and when I publish it into my Unity project. The error still exist within Substance Designer though.

I think I figured out the problem and solution.

When I first downloaded and started watching tutorials for substance, one of the steps in the tutorial was to create a copy of the packages folder and add that to the library. It seems as though if I used one of the duplicate procedurals that it had the error and it would cause several other procedurals to have a similiar error. However if I closed SD and used only the procedurals from the original package folder, those errors were not present until I used one from the new folder.

I unmapped the new folder and directed all my substances to the original folder and it appears to be totally functional now!

Thanks for the help.
Which tutorial was that ?

The 3.5 UI update. It's possible that at some point I may have missed a step or got confused and caused the problem. Luckily we got it figured out now.