Author Topic: Blur seams & hiding geo  (Read 2960 times)

Hello!

So i'm having a little problem with my newly purchased substance painter (awesome software btw).
I did a search for this problem on google and i have seen a small similar topic about it once before but there was no conclusive answer to it so i thought i'd ask again.

So i'm painting my model, and everything works fine, but as soon as I add a blur filter to a layer and crank it up a bit, I get a very apparent uv Seam (see attachment), and as there is as far as I can see no blur tool (yet), this is a bit of a problem (and hopefully the new blur tool that you guys are working on doesn't do the same btw)

Is there something I am missing, or a work around, or a fix on your end?

And, while i'm here.
Is it possible to hide geometry, like the eyelashes on my character are part of the mesh (without having give them their own texture set), but are a bit of a hindrance when painting?

Thanks!
Last Edit: February 05, 2016, 10:14:55 am

Hiding geometry is a currently know technical limitation and cannot be done. Usually the workaround is to use a new texture set instead.

The blur is a substance filter and therefore is done in UV space. That's why seams appear as you noticed it. There is no solution to that, that's a limitation of working in 2D space.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Thats a shame, guess i'll have to start making proper uv's again then.

Thanks :)

Hey @Tycane
This is a predictible issue: the normals are blurred on the 2D space, meaning that some info are "corrupted" on the 3d view...
do you have a padding on your normal map ? It could help diminish this issue

Hey Vincent.

I'm not sure really, I used SP's baking function to create it, i left the settings to default, i believe dilate width(?) handles that part, i didn't tweak any settings.
I also didn't save the file as I needed to re-uv my char anyways so i can't check.

I will do some testing this evening.

Thanks!

yes try to use the dilate (but don't expect too much ;) )

Has anyone found a workaround to blur a substance texture without using this blur filter in Substance Painter? Does one need to open the source texture in Designer to do this? There's already padding between my uv's, but one would need a huge amount of padding to make this default blur filter usable on a texture... otherwise it makes the UV seams show.  :'(

Thanks.

Does one need to open the source texture in Designer to do this?
As explained in a previous post, the blur filter works in 2D space and is unaware of the UV seams. The same behavior will happen in Substance Designer.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

As explained in a previous post, the blur filter works in 2D space and is unaware of the UV seams. The same behavior will happen in Substance Designer.

Okay, thanks so much for clarifying that. :)