Author Topic: 3ds MAX craches when I load a sbsar file in the Substance2 material from plugin  (Read 3310 times)

Hello guys, first I would like to thank you for your dedication to the community!

I have a question regarding a problem / crash I have when I try to load a sbsar file (downloaded from share.allegorithmic.comlibraries) in the substance2 map,  I automatically receive a crash report and 3ds max 2018 asking me do I want to save before it shuts down and then it shuts down!
It opens some sbsar files, like the ones in the  folders here that come with the plug in: Autodesk/3ds max/Maps/Substance/Noise
And some random sbsar files from the net, but most of them don't open.
Is it because they are made with earlier versions of the programs or something else?
But now that I think of it I tested a new one and it shutdown again, it was this one>

I would be really happy if you know the answer, thank you!

Hi Nedko,

The share link you posted only showed the query. If you could attach one of the sbsar files that doesn't work, I can attempt to reproduce it. If you have the version number of the substance2 plugin, that would be helpful as well.

My guess is that perhaps it's loading an old engine from the old plugin and it is failing to handle the newer files.

Since it might be a setup with your computer, I can try to have you test some of our test Substances Monday afternoon Eastern US time or Tuesday.

Galen Helfter
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Thank you for your fast response Glen!
 This it the message I get right after loading the sbsar file.

I the example above I loaded this sbsar file called "Exoplanet station wall cover" I downloaded from this link:

And the plugin I use I think it is the latest because I downloaded it yesterday from your official site ( substance_plugin-max-2.1.1 ) >

My 3ds max is a student version 2018, and I have Vray ABV 3.60.03

I don't know what info more I could give for now, I hope it is helpful.

And I will be happy to try some of your Substances, thank you for your time!

That should be enough information. I'll do a clean install of 3ds Max 2018 and run the installer on our website when I get back into work on Monday, and test it with the sbsar from Share and see if I can reproduce the crash.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Thank you so much for the support!  :)

Have you made the test, do you have the same problem with the crash?

Sorry, not yet. I ran a demo of the in-development Maya 2.0 plugin yesterday that took longer than I thought it would.

I only have 3ds Max 2019 installed right now, so I'll install Max 2018 and the plugin and test in the next few hours.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

I'm reinstalling 3ds Max 2018 now, so I should be able to test it when it's done.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

With a fresh install of Max and the 2.1.1 version from the website, I was able to load the sbsar.

What is the timestamp on the substance_linker.dll file in the Program Files/Autodesk/3ds Max 2018 folder?

The only thing I can think of on the top of my head is that the plugin may have failed to overwrite a linker or engine somewhere and it's somehow using an old one.

If you can reproduce it and get the crash log files from Max, that would be helpful as well.

I've also attached a test Substance file. Can you load that and change to each graph and see what happens? It succeeds on my machine but may fail on yours.

Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Thank you Glen!

Well it is strange but your sbsar test file is one of the few I can open with no problems and I even clicked on the button substance to Vray and the material translation worked like a charm, But as I said its one of the few that work,96% of other sbsar files fail on me!

This is the time stamp on the substance_linker.dll
also here is what it said when it crashed when I reproduced it
I am not sure if those are the log files you wanted, but I found them in appdata/temp, here they are:

Thank you, that should be very helpful. I'll see if I can find out where it crashed in our code and reproduce it, although it may take a bit to figure out where.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

I've been able to figure out an estimate on where it crashed from the dump file, somewhere in the loading code.

Do you have any Cyrillic or other non-Latin characters in the filepaths of the Substances that do not work? It could be that there's a bug in how we're handling paths with that.

I'll keep looking at it and see if I can reproduce it now that I know where it crashed. It may be that it isn't fixed until a future release, but I'll see if I can find a workaround after I reproduce it.
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

That was it, I managed to reproduce it by making a folder with Cyrillic letters in it.

A workaround might be to keep a folder for the sbsars high up in your folder structure, such as C:\Substances.

I've added a ticket for it, and we should have it fixed for the next release. It'll take editing some of the code to fix the issue.

Thank you for the help in finding out what was wrong.
Last Edit: January 30, 2019, 09:37:44 pm
Software Engineer, Integrations
Maya, 3ds Max and Core Libraries

Oh thank you so much Glen, and damn it, some years ago I had the same problem with 3ds max files when saved under Cyrillic alphabet (they crashed), and then I said to myself to watch out for this potential error in other programs as well, but I guess I forgot :D
I am happy that I was helpful as well!
I wish you all the best, and can't wait for the update!  ;D