Author Topic: 4.5 no textures without lights, environment lighting no longer works  (Read 11300 times)

4.5 no textures without lights, environment lighting no longer seems to work.  The problem may be limited to the diffuse channel.  New setting I don't know about?

Project that was working earlier, now isn't.  All shaders have the same issue.  Object has to be lit with a light otherwise it shows gray model without diffuse textures.

Loading a new scene from scratch with the default primitives shows the same problem.  I'm using older amd graphics drivers, my info is in this topic:,2704.0.html

Same for me BaseColor on non-metals only shows where my model is lit by a direct light. I'm on newest nvidia graphics drivers.

Try feeding the BaseColor through a Blend node then into the Output

Adding a blend node before the diffuse or base color output didn't work.  Tried both.  Thanks for the suggestion.
Last Edit: October 07, 2014, 07:17:37 am

Went back to 4.4.1 and tried to open a project file I was working on but I get a "file too old" error.  So I opened up a previous iteration that hadn't been worked on in 4.5 and half a dozen graphs that I hadn't opened in 4.5 were also "too old".  I'm assuming it's because they were in the newer project file and even though they were't speficially opened or modified besides the node itself sitting inside the project they were somehow updated.

One graph to rebuild wouldn't have been too bad but six, frustration is setting in, argh.  Think a couple were from the 50 textures pack but the others were custom materials I built.  Guess I'm going to choke on 4.5 with the basic lights and check Marmoset every few min.  See what Wes says tomorrow.

Hope others are having more luck.

@Eric Williams & horst-peter : Do objects appear black or do they appear grey ?

In the first case, it would mean the environment lighting is broken, in the second case it would mean the basecolor texture was not loaded by the graphics card (but in that case, using point lights should not work either).

I'm pretty sure it's the first case no environment or bad environment lighting. It's dark gray using any shader but lambert, I think not black because the reflections and fresnel are affecting the model?  But you can't see color information unless a light is directly on it.

Diffuse and Base color are both affected, doesn't matter if I load standard or metal or spec pbr.  Doesn't matter what shader I use, blinn, lambert or either of the pbr shaders.  Lambert shows the unaffected sides as completely black.  The others show some gray.

Blue box, should be blue all around but you can only see blue where the light is close to the box.
Lambertian and PBR metal.
Last Edit: October 07, 2014, 02:51:45 pm

Oh, I'd also like to add, direct3d 10 and sse2 both display the problem.

For your information, only the PBR shaders use the environment to light the object. So the result using the lambert shader looks ok.
And changing the engine actually changes the substance engine which computes the images in the graph / 2D View, it is not the 3D rendering engine in the 3D View3

But for the PBR shader, can you try to:
- open the attached package/graph
- in the 3D View: go to scene / Reset All, Materials / Default / Shader / Physically Based
- in the graph, right click / View outputs in 3D View
- in the 3D View, go to Scene / Edit and adjust the exposure as shown in the screenshot

thanks !

Product Manager - Allegorithmic

Loaded graph, reset all, set to physically based shader, right clicked put view texture in 3d view, scene settings exposure to 2.08.  And this is what I got.

I left the light values at their default, wasn't sure if you wanted me to adjust those.  They are on, light 1 dark gray and light 0 white.

Just noticed your post effects are off, turning mine off has very little effect.  I tiny bit of bloom disappears I think is all that's noticeable.

Diffuse and Base color are both affected, doesn't matter if I load standard or metal or spec pbr
For the Metal/Roughness shader, your texture should go in "BaseColor".
For the Specular/Glossiness shader, your texture should go in "Diffuse"

With the PBR shader loaded, can you please right-click on your BaseColor output and select "View in 3D View". This opens a menu with a list of texture inputs for the shader. Each texture input should display a small thumbnail of what texture is currently loaded in the 3D view for that particular slot. Would it be possible to post a snapshot of those thumbnails ? I would like to check what the other texture slots are like, because for example a black Ambient Occlusion texture would result in the kind of problem you have. A black normal map would also cause errors.

Output thumbs

SD 4.5 viewing correctly for me with both PBR modes/shaders.  I have a Geforce GTX780 graphics card.

Mines an older amd graphics card, it's been listed before in my other problem thread.  About a week ago amd put out a graphics card update that screwed up my viewport in SD.  Rolled back the drivers.  Now this SD patch is causing PBR to not work correctly.  My card isn't bad, was running the software fairly well the other day.  Still runs all the other software on my system just fine.  Not really in the budget for a high end new card at the moment.