Author Topic: Roughness in Unreal Engine looks inconsistent to Substance Designer  (Read 700 times)

Hello,

I created a Substance material and imported it into UE4 and noticed that the Roughness map in Unreal doesn't look the same as in Designer.

So far I've tried:
 - Checking/unchecking the sRGB tick box In Unreal
 - Changing the sampler type in the material editor in Unreal
 - Changing the components of the output in Substance Designer

Unreal


Substance Designer


Thank you,
Anthony D.

Does your material look correct though?
With the srgb tickbox unchecked, results should look correct in the 3d environment.
By default, substance displays the 2d view in srgb, even though roughness maps are exported and interpreted as linear.
I'm not sure how Unreal displays it in its 2d view, but either way, this doesn't really matter. The 2d view of the map can use the wrong colorspace while the 3d renderer uses the appropriate one.