Author Topic: Substance Painter crashing on dual monitor  (Read 367 times)

Hello

So I am working on a dual setup with a  huion 220 gt monitor. I have to always unplug it to load substance painter or else it crashes. It just has a blank white screen.

This page will guide you to find the log if it crashes at launch: https://support.allegorithmic.com/documentation/display/SPDOC/Exporting+the+log+file

Hi jeremie

Thank you for the quick reply. Here is the log file. I hope it helps!

Last Edit: January 03, 2019, 11:46:31 pm


Bump* Just checking is this fixable? :)

Regards

Saf

If you Huion 220 gt monitor plugged into your Nvidia GPU ?
Substance Painter may crash at startup because it tries to use the wrong GPU, which can happen when a monitor is not connected to the right GPU in the first place.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Hello Froyok,

I am using a laptop, the extra monitor is plugged into the hdmi port of the laptop. It works fine for other softwares Designer, photoshop, mzbrush maya etc. Its just painter that has the problem. My graphic card is a nvidia gtx 1080.

Kind regards

Safraz

If you are on a laptop, then make sure to force Substance Painter to run on the right GPU in the Nvidia drivers settings. You may need to create a profile for the application to do that.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.

Hello Froyok

Sorry I am not sure where to do this. I am looking under the nvidia controlpanel and there is a lot of settings I am not sure what I should change

Also my laptop doesnt have an intergrated GPU. Its a ASUS ROG VIK701 and comes with a nvidia 1080gtx

I dont have this problem with other 3d software including designer..
Last Edit: February 01, 2019, 12:26:35 pm

Hello guys,

We are having the same problem. Currently tested in 2 different pc's with different setup, both running windows 10.

1st one has 2monitors and the new cintiq 16. GeForce 1060
2nd has 1 monitor, the old cintiq 12. GeForce 670

Painter loads in the primary monitor and we can work and move its window around the desktop, but if we close it while is on any of the secondary ones, will not launch again. On star goes unresponsive.

I attached one of the log files after we ended the task.


Kind regards,
Borja

I am guessing there is no fix for this

Looking at the log file provided by @borparo I can see the thre monitor listed and the associated GPUs :
  • [INFO] <Qt> "[DBG INFO][RunTimeInfo]" "Device[0] driver-desc: NVIDIA GeForce GTX 1060 6GB"
  • [INFO] <Qt> "[DBG INFO][RunTimeInfo]" "Device[1] driver-desc: Microsoft Basic Render Driver"
  • [INFO] <Qt> "[DBG INFO][RunTimeInfo]" "Device[2] driver-desc: NVIDIA GeForce GTX 1060 6GB"
Looks like the problem is here : the Huion tablet is not running on the Nvidia drivers but rather on a basic one from Windows itself. If the system doesn't provide the right driver we won't be able to work with the GPU. Starting on the other monitor most likely force Windows to use the Nvidia drivers. I'm not sure there is a way for use to control that, this is more related to the Huion/Windows drivers instead which happen before Substance Painter starts.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Froyok aka Fabrice Piquet, Technical Artist and Product Designer at Allegorithmic.