Author Topic: Substance Designer won't launch on MacOS Mojave  (Read 1614 times)

I've tried launching the program many times, tried restarting, and multiple reinstalls. It shows the name of the program in the menu bar for a second then disappears and nothing happens. The log file is attached. I'm not using an egpu or anything, just stock machine. Specs below.

MacBook Pro (15-inch, 2016)
2.7 GHz Intel Core i7
16 GB 2133 MHZ LPDDR3
Radeon Pro 460

Hi,

According to your log file Designer stops at the very beginning of loading of the files.
I already saw such logs on previous versions of Designer when there is a conflict with another app.
We know that applications like PopClip, BetterSnapTool, Magnet, Better Touch Tool, Default folder X can prevent some of our app to be launched. So if you have an application that add or improve gestures, try to disable it.
 
Dwell control which is available in System preferences -> Accessibility can also affect our softwares.


   
   
QA Analyst

Thanks for the reply. I did have Better Touch Tool installed. I deleted it and all its related files, restarted my machine, and tried to launch Substance Designer. The same thing happened. The log file appears to have stopped at the same spot. I don't have any of the other software you mentioned. Dwell is in system preferences, but from what I could tell, it's not being used (there isn't a clear on/off selection for the feature, but no settings for it are set up and I don't use it).

Are there any other ideas? I'd love to be able to try this software.

Anything else I could try?

Hi,

Sorry for the late answer.
Do you have the possibility to send a crash report ?
Or if the crash reporter doesn't appear when you relaunch Designer, does Mac propose you to send a report ?
If yes, choose to see more details, copy all into a a text file and send it to me.
Those details are the only way to know what happen when a crash occurs.

Thanks !
QA Analyst

Substance Designer has never successfully launched for me. I can't access a crash report and MacOS doesn't prompt for one either. Is there a way to access the crash report without having to successfully run the software?

I created a new user and tried to launch it from there. It still crashed just the same, but I was given a crash report from MacOS this time. I've attached the text of that crash log.

Thanks for the crash report !

It will be really helpful !
QA Analyst