Author Topic: Scale issue when exporting GLTF from substance painter  (Read 2131 times)


So, I created a model in 3d max with scene unit scale set to Meters. I modeled a kettle with the size of:
Height: 22.0 c"m
Length: 28.44 c"m
Width: 12.36 c"m
* Please see ref image from max attached

I exported it as an FBX into substance in order to paint it and export the model as a GLTF format, however, once I export the model as a GLTF file the scale param are completely changed, and the scale of the model is changed drastically!
I know that because I tried to import the same GLTF into Blender (used an addon for that) and the model is HUGE! you can see ref image from blender attached along side the model size.
* Please noticed that the default scene unit scale of blender is set to Meters. So it can't be unit scale issue.

Also, we open the Json(GLTF) file that substance exported, and we can see there the change in the scale. please see ref image of the Json we are seeing.
Only when we change the scale param manually inside the Json into 1,1,1 the scale is working properly.

Why does Substance change the scale param in the GLTF when export?
is there a way for it not to do it?
Is it a bug? or a feature that is missing?
Am I doing something wrong in my workflow?
How can I preserve the scale of the FBX file I exported from my 3d software into substance?
I know you guys change the pivot while importing into substance, but are you changing the scale of the model as well?

*not sure if it is relevant or not, but the model contain out of 11 objects and 2 materials meaning 2 texture sets.

Please help! any help will do... :)

Thank you!


What are your export settings if you are using FBX ?
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.


I did some tests as I ran into the same 'issue'. The FBX export setting should be in meters, as that's how the units are defined in the gltf. That solved the problems I was having, as I used to export them in cms.