Author Topic: [SOLVED] 3D Viewport resolution problem  (Read 7479 times)

Hi, I'm new to substance Designer and I'm having a little problem with the 3d view in Substance Designer 4.4.1
All was working fine and the outputs were showing correctly until I tried to use one of the pbr examples in my graph. Now the object in the 3d view is extremely low resolution (as if it is mip-mapped). If I increase the tiling of the substance the 3d viewport object flashes momentarily at the correct resolution and then reverts to being very  low resolution. Any ideas where I am going wrong here?
Many thanks,
Last Edit: October 01, 2014, 10:58:54 am

Hi Matt,

It looks like the output resolution is very low (256). You need to set the base graph resolution while you work in SD. Double-click an empty area in the graph to load the parent graph attributes. Under base parameters, be sure that the output size is set to a resolution  you want such as 2K. To do this, set the graph to Absolute and then choose 11 for both the width and height.

Check this video. It describes how the resolution works and best practices for setting resolution.


Head of Substance Demo Art Team
Twitter: The3DNinja

Thanks Wes,
I already have the output set to 2k, so perhaps it's something else?

It looks like the maximum texture resolution in the 3D view is set to something very low. Could you check that it is set to at least 2048x2048 ? (the option is in Tools->Preferences...->View3D->Textures->Max Textures Size)

Thank you Cyrille,
That fixed it. For some reason, I did not recognize that there was a slider under the 3d viewport settings. I have no idea how I managed to slide it down to 16px!
Many thanks.

Sometimes, this slider seems to grab the focus, and then using the mousewheel will change the max texture size, when what you really wanted to do was scrolling down the window.