Author Topic: Newly added mesh to fbx file not updating in SP (Edit>Project Configuration)  (Read 1119 times)

I'm really hoping this is more of a PEBKAC issue than a bug.

I have a model where I have added additional geometry to the file. As seen below in Maya (note that I have everything assigned to the same texture "m_feathers"):



When I pull that texture set into my Substance project (Edit>Project Configuration) the project fbx does not appear to update, as seen below (texture name circled to confirm that the same texture name is being used):



However, creating a new project with that same .fbx  now has the added geometry :




Has anyone else experienced this and/or came up with a solution or workaround?

Edit:I'm attaching the correct log file from the project that is failing to update the model properly -- sorry, had submitted a log file from the test project beforehand.
Last Edit: November 30, 2018, 09:04:11 am

In your log file I see the following error :
Code: [Select]
[ ERR] <Qt> "[DBG ERROR][Assimp]" "Error, T10840: [FBX] : Mesh normals are invalid (some values are null) and will be recomputed"
[ ERR] <Scene 3D> [FBX] : Mesh normals are invalid (some values are null) and will be recomputed
Since you mesh is not perfectly clean and the mesh importer has to sanitize it, some data are lost.
Don't forget your log file. It can be exported from the Help menu of the software.
-----------
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.