Author Topic: Substance Image Input not working still?  (Read 3652 times)

So I thought some of the kinks might have been worked out since I tried it last, but I still can't get the image input to work in Unreal using my substance. I'm probably doing something wrong, but when I go to browse for an image in the instance nothing comes up, when I select use currently selected in content browser nothing happens, and dragging and dropping isn't working. It's for a normal map, could that be the issue? Just wondering how to get it working, thanks!

Hi Jason!

Make sure whatever image you want to use as a substance input is imported as a substance image. You will need to change the "file type" in the import window, like so:

Sorry for digging up the topic, but it would be nice to be able to import png textures (jpg is pretty bad for anything else than diffuse/baseColor).
Also, it would be nice to be able to use already existing (and so not imported as substance textures) images.

Allowing import of non destructive images (aka png/tga/etc) will be supported in the next release.

As for using regular Textures we can discuss that, but since standard UE4 textures do not support compression by default this may be non-straightforward.

Is there any way to import an image into a substance in 4.8? Nothing I'm trying seems to work.

Hi spete008,

Are you importing the substances as Substance Images? To do so you will click Import on the content browser and then in the file dialog that shows up, make sure the drop down is set to one of the Substance Image formats (jpg/jpeg/tga/etc). Otherwise UE4 will import it as a Texture2D.