Author Topic: Substance Error, can't read package  (Read 5748 times)

So maya crashed while calculating the nodes for my substance, and now whenever I try to use a substance I get the following message:

Substance Error, can't read package : /sourceimages/Table.sbsar

Happens with every substance I try.  I checked to make sure the plug-in was loaded, it is...


First, which version of Maya are you using?
Second, is 'Table.sbsar' a substance you've created on your own?
"Hinhin!" :-D

Using Maya 13 x64.  Yes, Table is a substance I created on my own, but it's just an example.  I get the same error with every other substance I use.  Table (and the others) works fine in Unity.

Ok, it looks more like a cooker incompatibility: Outdated version or too recent... But quite weird nonetheless.  :-\
Have you used the command-line cooker or have you published from Designer? If from Designer, then which version specifically?
May I ask you to share your files with me? Both *.sbsar and the source *.sbs file.
(You can send them via PM if you want)
"Hinhin!" :-D

The weird thing was it used to work, then maya crashed, and it stopped working.

Attached are the .sbs and .sbsar files..

Looks like I found the problem.

I tried to combine multiple output maps to the same output material (I put the Specular on the alpha channel of the diffuse).  Maya doesn't appear to be able to open these files.