Author Topic: SBSAR in Marmoset looks vastly different based on resolution  (Read 8226 times)

Hi !

I'm having an issue with designer and marmoset. In Marmoset, when I go over 1024 resolution of my imported SBSAR, the texture start looking vastly different, as If all the seeds get changed. This problem does not occur in designer, so I'm guessing it's an issue with the export.

Any idea what is cause this? I exported the file in relative to parents, but tried absolute anyway just to see, same issue.

Left is what the texture looks like at 2048, right is at 1024.
Last Edit: September 18, 2018, 12:19:38 am

Hi Jean-Bastien,
for differents reasons, some nodes like "edge_detect" can radically see their aspect change with resolution changes.
But you would see it in designer too...
We would have to see your graph for detect where your problem come from because it is really strange ;D.
Or at least, your sbsar for testing on our side.


Last Edit: September 18, 2018, 04:09:16 pm
Eric Lautard aka Janine Smith
Technical artist
Substance Source

Thank you for the quick response. Here is the sbs.
Last Edit: September 20, 2018, 04:52:22 am

I opened your sbs and found the same visual issue inside Designer between CPU and GPU engines mode.
I guess you are working with the CPU engine, you can check it by clicking tools menu/switch engine or press F9
You should work in GPU (2 on picture) cause few nodes like "edge_detect" (present in your graph) doesn't behave the same way in CPU.

Marmoset use Substance GPU engine, that is why it is not working ;)

Hope it helps
Last Edit: September 20, 2018, 03:44:02 pm
Eric Lautard aka Janine Smith
Technical artist
Substance Source

Hi! Thanks again for your help.

I seems to be on the right engine on my project. Also the issue is manifesting in UE4 as well, but is still fine in designer. Weird...

This post seems to have the same issue. Did you guys find a solution to it?
Last Edit: September 23, 2018, 04:18:38 am

I have found a less than ideal workaround.

I saved a bitmap of the edge detect and used it instead of the node itself. It worked, which confirmed that the edge detect is the issue.

This goes again the purpose of a non-destructive graph, but work for the time being. I still would be interested to know if there is a solution