Author Topic: 2d Viewer broke after 2018.2.2 update  (Read 2663 times)

In the video you can see the broken 2d viewer, also, can't select the transformation handles or move the brushes.

This is a different issue, but it also concerns the flaw in the 2D viewer that happened after the current update. I'm unable to pick geometry, islands or polygons in polygon fill mode.  I was able to do this prior to the update and I'm able to pick islands and polygons in 3d mode. It might pick one or two, but for the most part it ignores all the geometry.

OK, I did a little testing of this.  I installed previous versions of Substance Painter and the file I was working on was still unable to choose islands or polygons in polygon fill mode. After changing a bunch of possible parameters (format of the mesh (OBJ, FBX) baked maps and no baked maps, Empty folder mask or Smart Material mask) the original file was still not working.  I started anew with the same mesh in a previous version (I started with 2018.1.3) Substance Painter and everything worked. Then I moved up through the versions and when I stared anew I was able to make masks with polygon fill. Finally, I reached 2018.2.2 and when I started fresh, I was able to choose polygons and islands for the mask.  I'm not sure why it failed in the original version of the file. The mesh was the same, the bake maps were off the same hi-res model and in the same format (FBX).
Last Edit: September 14, 2018, 04:26:01 am

I am having the same issue. It is impossible to use the 2D view to paint the UVs after the update.

A fix is being worked on.

I reported two bugs related to this. Glad to see I'm not alone-- and glad someone's trying to fix it. I'm somewhat stuck until then...   :(

A workaround for now is to open the default "start painting" file from the startup window. From there, create a new file. Your 2D view will be fixed.
3D art is magic.

I reported two bugs related to this. Glad to see I'm not alone-- and glad someone's trying to fix it. I'm somewhat stuck until then...   :(

Having the same issue here. 2018.2.2 is busted with respect to the 2D view (polygon fill and such).

Same here, the 2D view is sooooo broken... :/

First time the new version is an ugly mess like this...

Tips if it can help someone :

Before creating a new project, open an ancient one (a clean one!). THEN, you create a new one. It works for me... And the new project is now clean (so far...).

For those who have a broken project.

Open the broken project and export a smart material with everything in the layer box.
Open an ancient project, THEN create a new one with the object of the broken project. The new project will be clean.
Drop the smart mat in the layer box.

Voilà, c'est tout beau et tout propre!

It worked for me, was a pain in the ass, but I managed to clean 5 projects like that, now they work fine for me.

But Please Allegorithmic, clean this ASAP!

Hope it will helps some of you.


The problem for me seems to be unique to the OBJ format. FBX seems to import without issue.