Author Topic: Re-importing Substance Designer files in UE4 marks them for delete in Perforce.  (Read 721 times)

Hey everyone,

Everytime I re-import my substance files to UE4, Peforce marks them for delete rather than being checked out. Causing me real issues at the moment. Any input?

Thanks!


Hello, I was looking for a solution to my problem and I believe I have a connected issue/know part of the answer.

When I update my graph and recook sbsar, Unreal detects the change and reimports the file (I see the small pop-up), but the connected instance doesn't show new parameters that I added to the graph, until I reimport the sbsar manually.

As if that wasn't cumbersome enough, while reimporting manually, the plugin actually deletes the instance and generated texture (hence the perforce "mark for delete"), and even though it recreates them immediately, by that time the texture is gone from the material (shader) that was using it, causing material compiler errors and forcing me to manually plug the texture into its sampler again.

Am I doing something wrong?

Hi all,
So this occurs when you re-import a Substance because changes could have been made to the Substance that would require a regeneration of the outputs. This does cause an issue with Perforce and we will investigate ways in which we can prevent this from happening. There is no quick workaround to this that we know of but if we find anything, I will post an update here.

Thank you for the feedback!  :D
Cheers!
Software Engineer, Integrations
daniel.stover@allegorithmic.com

Bumping this thread in hopes of an update.