Author Topic: Problems Upgrading 2017 scene to 2018  (Read 1211 times)

Hey,

I'm having issues with the substance update custom package when trying to update my scene's substances from 2017 to 2018. I think the issue might be specific to MacOS. I ran through the video released on the official Youtube page, and an issue I encounter was that I never got the --Reflection-- menu, after changing the Editor settings serialization to Force Text. The menu just doesn't appear anywhere, and there is a error that occurs, related to the Reflection.dll.

Just wondering if there is anyway around this, as I would really like to translate my project to Unity 2018.

Hey,

I'm having issues with the substance update custom package when trying to update my scene's substances from 2017 to 2018. I think the issue might be specific to MacOS. I ran through the video released on the official Youtube page, and an issue I encounter was that I never got the --Reflection-- menu, after changing the Editor settings serialization to Force Text. The menu just doesn't appear anywhere, and there is a error that occurs, related to the Reflection.dll.

Just wondering if there is anyway around this, as I would really like to translate my project to Unity 2018.

Hi,

Could you please post the error you are seeing? Did you import the update package that we provide on the documentation page? With that package imported, you should be seeing the reflection menu option.

Cheers,
Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

Hey Wes,

I realized that I had already updated to 2018.1 before I downloaded and installed the substance update file from the youtube video link. So it was my mistake, but at least this proves out that you cannot update correctly having already downloaded and installed 2018.1.

Hey Wes,

I realized that I had already updated to 2018.1 before I downloaded and installed the substance update file from the youtube video link. So it was my mistake, but at least this proves out that you cannot update correctly having already downloaded and installed 2018.1.

HI Conrad,

You can't update from 2018 with the current build. In the next update, we made fixes which should potentially allow this to work. The issue is how Unity handles UGUID. We will have the next update releasing soon.

Cheers,
Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja