Author Topic: Sbsar in UE4 generates different maps than in substantce designer & player  (Read 604 times)

Hi!

I have a strange problem with one of my selfmade materials. When I import the sbsar to ue4 all my maps are without grass. there are some exposed variables, but no matter how i adjust them, i cant get the grass part of my material back. It should be there with the default settings and it is in substance designer and in substance player. does someone of you have similar porblems? I did many materials before and never had this issue.
I allready did a reimport, i've deleted everything and exported it again from substance designer and i deleted my maps and generated them new from the Inst file inside ue4. everytime the same result.





thank you for your help!
Last Edit: June 10, 2020, 12:37:53 am

Hi!

I have a strange problem with one of my selfmade materials. When I import the sbsar to ue4 all my maps are without grass. there are some exposed variables, but no matter how i adjust them, i cant get the grass part of my material back. It should be there with the default settings and it is in substance designer and in substance player. does someone of you have similar porblems? I did many materials before and never had this issue.
I allready did a reimport, i've deleted everything and exported it again from substance designer and i deleted my maps and generated them new from the Inst file inside ue4. everytime the same result.





thank you for your help!

@bobokox ,

Can you attach the .sbs file as well? I'll take a look :)

hey keston!

thank you very much!
I attached the sbs to the first post!

hey keston!

thank you very much!
I attached the sbs to the first post!

Hey @bobokox ,

It seems the .sbs file is fine! All you should have to do is switch from the CPU engine to the GPU engine in the UE4 Project Settings under the Substance section. Some of the nodes in the .sbs are GPU only, and by default the UE4 plugin uses the CPU engine. :) Hope it helps.


Hey keston!

Yeah, it worked!
thank you very much.