Author Topic: Substance Plugin 1.0.0 for 3ds Max 2018 and 2019 Released  (Read 68078 times)

Hello Everyone,
The new 1.0.0 version of the plugin is now available which is now out of a beta state.

Blog Post:

Download Link:

Release Notes:

We love feedback and if there is any way you believe the plugin could be improved or if there is a feature that would greatly improve your workflow, we would love to hear from you!  :D

Legacy Updater:
For those who are still using or would prefer to use the legacy Substance integration within 3ds Max, details and the download link for the legacy plugin updater can be found here:,14223.0.html

Last Edit: April 16, 2018, 08:19:31 pm
Software Engineer, Integrations

I first started using the Beta plugin less than a week ago. The plugin didn't work after installation. I explained that in another thread.

I just downloaded the new full release. I could not find a way to uninstall the Beta. It did not show up in "Windows Uninstall" or "Revo Uninstaller Pro." I installed the new release without doing an uninstall. When I opened Max 2018, I got message #1. I changed the name of the "Old Class" and re-started Max 2018. This time I got Message #2.  I uninstalled the new release "1.0.0." When I re-start Max 2018, I still get message #2. When Max 2018 opens there are no references to "Substance," in Slate, not even the legacy version that came with Max.

I've made a mess. Can you help me? Please. Thanks. (Should I move this to another thread?)
Max 2018
Maya 2018
DELL Precision T7910
Intel Xeon CPU ES-2667 v3 @ 3.2GHz
NVIDIA Quadro M5000

Last Edit: April 12, 2018, 06:31:45 pm

Hi @foglevel,
I would be happy to help! I will also add a ticket in to make sure that we restore the default Substance files upon uninstall so that the original plugin does not break.  :)

The first step is to get max working back to a default state. If you have uninstalled all of the plugins and the updater (which it looks as though you have) first run the Substance updater which will restore the needed files for the initial plugin.

This can be found here.,14223.0.html

From here, 3ds Max should work as it had before installing the plugin. After this is confirmed, it should be as simple as running the new 1.0 plugin installer.

We also have updated the installer to prompt for uninstall but as it was not present in the original/beta uninstaller, for the first update, this will not be available. This process will be easier in the future.

Let me know if this helps and you are able to get it working.  :D
Last Edit: April 12, 2018, 07:33:58 pm
Software Engineer, Integrations

The plugin is working with Corona brilliantly! Even with Corona Interactive! Great job Allegorithmic and especially the 3ds Max team, I've been waiting for this day for a long long time.

I did have some toruble installing it at first as well but I uninstalled the plugin with the plugin uninstaller found in: \Program Files\Autodesk\ 3ds Max 2018\

I also removed the old plugin from: \AppData\Local\Autodesk\3dsMax\2018 - 64bit\ENU\usermacros

After that I reinstalled the new plugin, and restarted the computer. Works perfectly after that with no more error messages.

Is distributed rendering supported with this version?

Is distributed rendering supported with this version?

This version does not yet support distributed rendering but this is a high priority. You can expect support for this within either 1.1 or 1.2 versions of the plugin.  :D

Software Engineer, Integrations

Thanks Jamesjwgallagher. I looked in my usermacros folder and found "Substance-SendToSubstance.mcr." Is that the old version you referred to that needs removed?

Dan, before I do anything else, I followed your instructions and this is what happened:

I installed the updater without any issues. I opened Max 2018 without any messages. I opened Slate and found the legacy "Substance" where it is supposed to be.

I closed Max and installed the new release (substance_plugin-max-1.0.0.exe) without any issues. I started Max and got 4 consectutive messages (attached). I clicked "Yes" on each one, in the order that they are numbered. After the 4th msg, Max opened.

I, then, opened Slate. "Substance" and "Substance2" were, both, in their proper locations. I created a "Substance2" node and assigned a file to it. I clicked on the "Substance PBR to Vray" button in the tool bar and got a message (see attached screen cap).

I created a legacy Substance node, assigned a file, and clicked the same "Substanbce PBR to Vray" button and it created the Vray stuff.

There is no Substance menu item.

Sorry for all of the large images. I can take them down after you look at them. If these don't mean anything to you, I'll remove the macro that Jamesjwgallagher mentioned, reboot, and see what happens.

Removing the macro eliminated all but one of the messages. It eliminated "SendToSubstance." Nothing changed in Slate. I don't see anything else in the folder that refers to Substance.

Hi @foglevel,
Thanks for the feedback! So I have one more step. :D
(Sorry again for the trouble, and as mentioned, this will hopefully and expected to be the last of it!)

So those messages mean that the original beta plugin did not get uninstalled. If you head to the following location, it should just be a matter of removing the old plugin manually.

<3ds Max Install Location>/Plugins/substancemax.dlt

Removing/deleting this should clear up the messages and will allow the new plugin to load without issue.

Keep us posted!  :D
Software Engineer, Integrations

That did it. Everything seems to be working perfectly. This is my first serious exploration of Substance software and PBR. It's like going to Disneyland everyday. Great software and great support. Thanks.

Hi @foglevel,
We are always happy to help!
Glad to hear that you were able to get it working and that you enjoying using the Substance tools!  :D
Software Engineer, Integrations

So... any chance this will be extended to 3ds Max 2017?

In 3dsmax 2018 when adding substance2 into map slot it crashes. In 2019 all works okay.

After installing the new plugin over the old one I got the same error as above and delt with it but now despite my plugin working fine all my old scenes with the old plugin crash. So if I start a new scene and use substance plugin there it works great. Trying to open old scenes where the older version of plugin was used and it crashes right at the start. Good thing I kept the installation file of the old one too. It works ok when I go back.

EDIT: I know you warned us that the plugin is not working with previous stuff but what I wanted to bring to your attention is that it literally made the scenes impossible to open and it would have been a ton of work to rework all the stuff.
Last Edit: April 13, 2018, 10:52:05 am

I followed the steps of deleting the 'substancemax.dlt' file and then installing the new plugin, and all worked great in 3ds max 2018!

Does anyone know whether this plugin will be updated to work natively with the ART renderer built into Max? It doesn't convert substance materials to anything that ART can read like it does if you press say ' substance to vray'. I know you can create a new physical material and hook up the nodes between the substance mat and the physical mat, but I haven't managed to get it to work yet, and its also not a 1-click solution like it is with the other render engines.  :-\