Author Topic: Cannot download Substance Source in Substance Painter  (Read 3419 times)

I tried to download the materials from Substance Source in Substance Painter.
I had no problem logging into my substance source account and browsing the material, but once I clicked the download, this message showed in the log:

file:///C:/Users/Yolanda/Documents/Allegorithmic/Substance Painter/plugins/substance-source/main.qml:855: ReferenceError: propDetails_hashIndex is not defined

Anyone has the same issue or knows how to fix this?
Thank you.
Chien Jarvis // 3D Artist
Artstation:
https://www.artstation.com/chienjarvis

Same here...I have 400 available downloads to use but cannot download a material in substance source in Painter...

Having same issue - same error message as OP.

Thanks
Daf
I dont have enough people words to make it understand you the way it understands me

The issue is being fixed and will be part of the next update on Tuesday.

This issue is fixed!

I am still having this issue.
[Script] file:///C:/Users/rober/OneDrive/Documents/Allegorithmic/Substance Painter/plugins/substance-source/main.qml:855: ReferenceError: propDetails_hashIndex is not defined

Been trying for 3 days now to download from substance source every time download failed.
This is from web site and also the substance painter plugin.
I have also downloaded and installed  the new substance painter plugin, still not working, it also seems like it has been taking the points for the down


 
Last Edit: May 09, 2018, 07:49:01 pm

[Script] file:///C:/Users/devotid/Documents/Allegorithmic/Substance Painter/plugins/substance-source/main.qml:852: ReferenceError: propDetails_hashIndex is not defined

This is all I get Please advise what to do.

Thank you.

SP 2017.3.3

Hi @devotid

Would you be able to update your version of Substance Painter?
PO @ Allegorithmic

I'm getting the same issue as devotid, on the Steam version of 2017 (2017.3.3)

@Marion Marchive The newest version available to me on the Allegoriithmic site is 1.7.3+1080 which has a release date of 01/01/2017. Is this an error?
Last Edit: June 27, 2018, 07:59:56 pm

Hi @Dave-3D

The newest version available to me on the Allegorithmic site is 1.7.3+1080 which has a release date of 01/01/2017. Is this an error?

It looks like the latest version of Substance Painter you purchased (or the last one you syncronized from your Steam account) was Substance Painter 1.
It you purchased a more recent version of Substance Painter on Steam please syncornize your licences by going to the "Steam" tab in your profile on the Allegorithmic website.
PO @ Allegorithmic

Ah yes, I had presumed the synchronization was permanently in effect. Re-done just now and currently downloading 2018.1.3.

Cheers Marion!

I've run into an issue actually. I've attempted to activate the license using my www.allegorithmic.com account and also by downloading the license file. Both methods return a message saying that my license is not valid for this version. This seems a bit odd as the license file is provided alongside the download link for this particular version.

Am I doing something incorrectly?

Apologies if I'm derailing this thread.

EDIT: I've found conflicting information between the "Steam" tab and the "Licenses" tab, the "Steam" tab is where it says 2018.1.3 and under "Licenses" it says 2017.3.3, I'll report back after testing that version.

EDIT 2: 2017.3.3 installs and runs, though the log window shows "[Plugins] substance-source plugin requires 1.1.1 API version or higher while current version is 1.0.8. Please upgrade your Substance Painter version to use this plugin." and then when I try to select a new material on Substance Source I get the same error in the log window as I did with the Steam version "[Script] file:///C:/Users/Myrddion/Documents/Allegorithmic/Substance Painter/plugins/substance-source2/main.qml:852: ReferenceError: propDetails_hashIndex is not defined".

EDIT 3: And I've only just noticed that the website version I've downloaded and installed is exactly the same as the Steam version anyway.
Last Edit: June 29, 2018, 07:50:14 pm

You'll find un update to the Substance Source plugin for 2017.3.3 that fixes your issue in the documentation: https://support.allegorithmic.com/documentation/display/SPDOC/Substance+Source

You'll find un update to the Substance Source plugin for 2017.3.3 that fixes your issue in the documentation: https://support.allegorithmic.com/documentation/display/SPDOC/Substance+Source
That did it, cheers Jeremie!