Author Topic: Substance painter crashes immediately it starts  (Read 5584 times)

I want to purchase substance painter so I decided to go for the free trial before purchasing the software but after downloading and installing substance painter it starts for about a second and then closes I sent a bug report I was told to uninstall and reinstall my graphics driver, I did but the same thing keeps happening  I am using a laptop with Intel HD graphics 520 core i3 6100U 6 gig ram is there anything I can do pls

Integrated GPUs are not supported in Painter. A dedicated graphics card is required with at least 4 GB of VRAM (as I see it your graphics card has none of that at all using your system RAM, which will most likely not work with Painter at all).

You will also not get very far with just 6GB of RAM nowadays, so you might want to consider getting a new PC.

You will probably not get Painter to run on your system at all.

Yes, we support certain integrated GPUs, as long as they meet the requirements mentioned on this page. We do not recommend them though, and dedicated discrete GPUs should be preferred when available.
There seem to be a problem with the new 2018 version of Painter and integrated Intel GPUs we are supporting. We will investigate.

I really love the look of the new interface and all that the latest Substance Painter release seems to offer.
- [Viewport] Smoother navigation and painting (higher frame rate)
- [Tablet] User experience enhancement while painting
- A whole list of other cool things.

I am gutted that it will not run on my Surface Pro 4 though.
Zbrush and 3DCoat work well for me but Substance does have some really cool features. Is there anything at all I can do?

I have a desktop with a paltry gtx 960, an old laptop with a gtx 660 and a MacBook pro with a Radeon Pro 560 and a Yiynova DP10 U graphics tablet with a screen but I really, really love the experience of sculpting, painting, drawing on my Surface.

Is it just not possible with the new release?
 :'(

We are fixing a few issues with integrated graphics in the next hotfix, it may solve your issues, but no guarantees.

I too bought a Surface Pro just for that! it handled 2017 pretty well, SP 2018 should run even faster now!
What does that means "No guarantees", are you leaving your users in the dust now with buggy software? Better that hotfix works!

We all hope the bugfix will work.
That said there is nothing "buggy", as your hardware has to be aligned with the tech requirements:
https://www.allegorithmic.com/products/tech-specs

Most of integrated graphic chips are not supported by default (even if we manage to make it work in some cases).
Thx

We all hope the bugfix will work.
That said there is nothing "buggy", as your hardware has to be aligned with the tech requirements:
https://www.allegorithmic.com/products/tech-specs

Most of integrated graphic chips are not supported by default (even if we manage to make it work in some cases).
Thx
It is very well aligned with tech requirements, it's the latest Surface Pro 2017.

What is the GPU within it?

What is the GPU within it?
Intel HD Graphics 620

Quote
Intel HD Graphics 620

Different model laptop (HP x360), but ditto. Same GPU and same problem. Worked perfectly in previous versions.
Last Edit: March 29, 2018, 12:18:47 pm

So sounds like Substance Painter might be a no-go for most laptops?

We fixed a bug with integrated graphics in 2018.1.1 released on April 3.

Cheers,
Head of Product Management

Tried today...major problems with 2018.1.1 on Intel HD4400...2017 seems relatively functional though. GUI does look much better in 2018, although it doesn't keep all the menus onscreen properly when maximized.

Crashed the drivers once...seemingly...screen went black and had to hard reset the machine.

Here is some info to make it easier to make it function properly:
Turn off morphological antialiasing in the Intel graphics control panel to prevent major problems. After that, the first White brush works great...then select that blue fabric material...try painting with that...viewport stops responding...

Hope the app can function properly on Intel soon. Thanks in advance!

Last Edit: April 05, 2018, 03:09:39 pm

Tried today...major problems with 2018.1.1 on Intel HD4400...2017 seems relatively functional though. GUI does look much better in 2018, although it doesn't keep all the menus onscreen properly when maximized.

Crashed the drivers once...seemingly...screen went black and had to hard reset the machine.

Here is some info to make it easier to make it function properly:
Turn off morphological antialiasing in the Intel graphics control panel to prevent major problems. After that, the first White brush works great...then select that blue fabric material...try painting with that...viewport stops responding...

Hope the app can function properly on Intel soon. Thanks in advance!

Interestingly enough, yesterday my screen started flickering and went black, restart didn't solve it so I had to hard reset.
I didn't think it was related to SP but now I do.
Can you share more about this? I was gonna return the unit for refund.