Author Topic: Wacom Pen Buttons  (Read 3348 times)

Hi,

no matter which changes I make to the wacom pen settings (assigning right and middle click to the two pen buttons) - it doesn't affect the viewport navigation in substance painter.
Seems like the mapping is locked.

what am I missing here? thanks for your help!

There is something awry with the pen button preferences, I noticed this also. I have actually reversed the pen button assignments in the Preferences so navigation kind of is correct in the viewport, but I now have to middle-click (I think) to access the right-click menu.

Annoying. They should fix this asap.
Last Edit: March 23, 2018, 10:43:37 am

Hey, This is happening to me too.  Painter isn't recognising my wacom setup, either the default or if i create a specific profile for painter.  Currently it seems locked, the MMB is always at the top of the rocker switch and the RMB is at the bottom regardless.

Have you double checked your Wacom driver? I'm having the same issue on my Cintiq but haven't checked the Wacom driver yet.

yes, I have double checked my wacom driver

substance painter 2018 is simply ignoring the wacom tablet property settings

I just replied to another similar thread. I found that an odd workaround is to swap the shortcuts, so set:

- Camera translate: Alt+Right
- Camera rotate: Alt+Middle

This made my table work as intended, but then made the mouse controls backwards. For me, this was fine since I'm using the tablet for navigation exclusively.

EDIT: Derp. Noticed volker already mentioned that workaround and other gotchas with it.  :o
Last Edit: March 25, 2018, 07:20:44 am

Same thing for me. It's only affecting the viewport and completely ignores what I set the driver settings to. Reproduced this with my Wacom Cintiq Pro 16.
The workaround does work but as tnydwrds mentioned this messes with the mouse input.   

same, they keep inverting for some reason, overriding the wacom settings. (If I try to invert them back in the wacom driver settings these settings will get ignored)

Confirming this also. Very annoying.

Also... is their open improvement/bug reporting system gone? I loved that one, seemed very practical.

It is still here and we are still monitoring it :)
https://allegorithmic.uservoice.com/forums/261284-substance-painter

Ah, great... my google skills failed me then. Bookmarked.

It is still here and we are still monitoring it :)
https://allegorithmic.uservoice.com/forums/261284-substance-painter

so is uservoice for bugs as well? I thought, this was more focused towards general ideas about features and improvements

would you recommend adding this wacom issue to the uservoice site?

seems like there is a conflict between painter and the wacom driver:



I'll reinstall painter 2017

would be great to get a response about the issue from allegorithmic (not just a link to uservoice)

Last Edit: April 02, 2018, 02:59:08 pm

Confirming this. Very annoying.  :'( Please support us and help to repair this bug. Thank you.

so is uservoice for bugs as well? I thought, this was more focused towards general ideas about features and improvements
would you recommend adding this wacom issue to the uservoice site?

No, please only use Uservoice for feature requests.

Bug reports should be reported through this page instead (the button on the right side of the screen) or through the "Help->Report A bug" menu of Painter/Designer.