Author Topic: Wacom Pen Buttons  (Read 3308 times)

thanks Cyrille

I'll update Painter at home and see if the issue is still there (in the release notes, it says "fixed: [Tablet] Issue when changing default interaction choices", so this might be addressed already)

installed SPainter 2018.1.1

the issue has been fixed, thanks!  :-*

I also had to delete the application specific preset in the wacom tablet properties menu, otherwise the changes in that menu didn´t have an effect on painter.


I swear it worked after the update the last time I started - but currently the right pen button doesn't work at all in the 3D view.

did you try deleting any custom spainter wacom preset (in the wacom tablet properties)?

For those having trouble with this, make sure you have your mapping set to "mouse" in the Wacom prefs.  Worked for me on Mac anyway.   /dj

Guys I just downloaded the latest version of Substance Painter 2018.2.1, also i just updated my wacom drivers and it's a nightmare. I created the specific set of controls on the wacom properties window for SP and changes to shortcuts were completely ignored by SP, then I tried to set the mapping to "mouse" in wacom pref. (as @davidjenne suggested), and after 2 minutes of weird tweaking SP started working as I want. But after 10 minutes of work it just got back to the previous behavour, even if the new shortcuts are still there in SP's settings. I also tried to delete the SP preferences from the wacom configuration as suggested by @michael_11 but with no luck.

PLEASE HELP!!  :C

Working on Windows 10 and Wacom IntuosPro Small

thank you

Ok so the only workaround that i found so far is:

when you jump from SP to another application and then back to SP, the software kinda "forgets" that you're using a pen, so you just wanna do a simple MOUSE CLICK in the 3D view (I do a middle mouse click), and then you should be able to use the pen cause SP will start take into consideration the new shortcuts.

Hope this helps!

Cheers