Author Topic: MODO 801/901 Plugin Open Beta  (Read 97668 times)

Hi, quick question I'm using the latest build of Modo 801 SP4 beta, Substance plugin 2.0.0 -RC2-Build 116, and the latest nvidia drivers.
I can load a substance Sbar Ok and turn on the outputs fine. The problem is they show up in the Advanced open GL preview but not the F8 preview or F9 render.
Wes can you see if your getting the same problem.
I'm not sure if it's a bug in Modo, the substance plugin or I'm just missing a step.
thanks.

Oh one note the Height map will show up in the F8 and f9 render ok. But nothing else, like diffuse, does.

Hi,

It sounds like the substance was created above the shader. Can you post an image of your shader tree? If the substance is above the shader, it won't render.

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

Hi, quick question I'm using the latest build of Modo 801 SP4 beta, Substance plugin 2.0.0 -RC2-Build 116, and the latest nvidia drivers.
I can load a substance Sbar Ok and turn on the outputs fine. The problem is they show up in the Advanced open GL preview but not the F8 preview or F9 render.
Wes can you see if your getting the same problem.
I'm not sure if it's a bug in Modo, the substance plugin or I'm just missing a step.
thanks.

Oh one note the Height map will show up in the F8 and f9 render ok. But nothing else, like diffuse, does.

Hi,

It sounds like the substance was created above the shader. Can you post an image of your shader tree? If the substance is above the shader, it won't render.

Cheers,

Wes

Oh duh. That's what I get for going on vacation for two weeks and not working in modo.
Thanks.

Hi Wes,

Thanks for the 801 plugin!!!  I have been playing with the plugin and your test scene/assets.  I really like the modo integration!!  I am getting a crash on export to FBX with the "materials" option checked in the FBX export settings.  The maps bake out and the scene geo export fine with export materials off.  The provided file "SubstanceTutorial_Complete" also crashes on load.  I am on a 2013 Mac Pro, Modo 801 SP3,  RC2 Build 116. 

Thanks,

Dave


Hi Wes,

Thanks for the 801 plugin!!!  I have been playing with the plugin and your test scene/assets.  I really like the modo integration!!  I am getting a crash on export to FBX with the "materials" option checked in the FBX export settings.  The maps bake out and the scene geo export fine with export materials off.  The provided file "SubstanceTutorial_Complete" also crashes on load.  I am on a 2013 Mac Pro, Modo 801 SP3,  RC2 Build 116. 

Thanks,

Dave

Hi Dave,

For the crash on FBX export. Is that an FBX exported from modo and then you are getting a crash in Substance Designer with baking?

The "SubstanceTutorial_complete" is for 701. I will need to update that. You should be able to use the convert substance from 701-801 option. I will give that a try and will also update the files.

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

Quote
Hi Dave,
For the crash on FBX export. Is that an FBX exported from modo and then you are getting a crash in Substance Designer with baking?

Modo is crashing on export to FBX when the material option is checked (see the screen shot) in the modo export preferences, preventing transfer of my textured scene to other applications.   Unchecked, the scene exports without crashing modo, however the materials are no longer intact.

Quote
Hi Dave,
For the crash on FBX export. Is that an FBX exported from modo and then you are getting a crash in Substance Designer with baking?

Modo is crashing on export to FBX when the material option is checked (see the screen shot) in the modo export preferences, preventing transfer of my textured scene to other applications.   Unchecked, the scene exports without crashing modo, however the materials are no longer intact.

Do you have substances in the materials in modo?

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

Hi,

We have build 132 ready for download. I updated the link and build notes in the first post.

Cheers,

wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

Hi, Wes,

nice to hear/see that there is development going on. Were the devs able to find and fix the issue with that metal material I tried to discuss by mail?

Marc

Hi, Wes,

nice to hear/see that there is development going on. Were the devs able to find and fix the issue with that metal material I tried to discuss by mail?

Marc

Hi Marc,

We haven't resolved those particular substances yet. It looks to be an unsupported parameter that is causing the crash. The development is ongoing and we are sending releases to Luxology QA as well until the official release.

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

I was following along with the Modo Substance tutorial on Windows 7 with Modo 801.
http://youtu.be/jmM1xGWtDNM

The first step in the video uses the menu item:
Texture->Substance->Open A Substance

The only menu item that I can see is:
Texture->Substance->substance.create Control+Alt+S

That menu item creates a material.SubstanceMaterial and the properties only show a single "substance.params..." option.

I have the latest Modo 801. And I grabbed the latest plugin from:
http://www.allegorithmic.com/substance-modo

Cool plugin! I want to play :)
Last Edit: January 25, 2015, 09:25:41 pm

Hi tgraupmann,
from memory, I think that the vid, was made for substances in Modo 701, maybe early 801 (?), so there are differences in the shown workflow. Certainly modo 801 caused a few issues with the plugin in the early stages. Using the latest beta plugin build 132 with 801 sp3, should have that selection as "create substance (ctrl alt s). Odd titles/fields here to me would indicate you have an earlier version of the plugin running in modo.
Anyway, the other thing that may be different (and did cause me a few headaches initially..) is the workflow is a bit different nowadays. That is afaik, you need to have a material tagged and selected for the polys you want to texture in modo and then invoke the "create substance" function from the texture dropdown. Otherwise it puts the substance above the base shader and hence won't display until you move it.
The other thing that also may not be obvious is that once you apply the substance, you need to load a substance and then goto substance props and select the outputs you want.. ie click on diffuse, bump, normal etc..
I've attached a pic, hopefully it makes sense.
I'm definitely not expert on substances and there may be a better way to do this, and/or automate some of the steps, but crudely this is what I do.
Cheers!


Ah yes the first page of this forum page has the most recent release candidate of the plugin:
http://forum.allegorithmic.com/index.php/topic,2296.0.html

The download page links to the old beta 11:
http://www.allegorithmic.com/substance-modo

Okay some workflow enhancements.

1. Make all the outputs checked by default

2. Control+Alt+S makes a new material and the properties show Substance Properties where you can click Load sbsar. After loading a substance, the Load sbar button goes away. The enhancement would be when the reset button is clicked, the load sbsar button would reappear.
Last Edit: January 26, 2015, 08:57:32 am

Moin,

> The other thing that also may not be obvious is that once you apply the substance, you need to load a substance and then goto substance props and select the outputs you want.. ie click on diffuse, bump, normal etc

... or use the "substance browser KIT" discussed above (downloadabe from the ex-Luxology-Forum "Share" Dep.). The KIT allows you to select a substance from a preview list, load the substance and auto-enable all channels it owns.

Marc

I snuck in a little talk about the Substance plugin for Modo in our hangout today, right at the end. :)

(29:30) Starts at 29 minutes 30 seconds - 29:30
https://www.youtube.com/watch?v=KQTKq2TQqaU&t=29m30s

The forum plugin here doesn't read the time index...
Last Edit: January 26, 2015, 10:01:14 pm

I was following along with the Modo Substance tutorial on Windows 7 with Modo 801.

The first step in the video uses the menu item:
Texture->Substance->Open A Substance

The only menu item that I can see is:
Texture->Substance->substance.create Control+Alt+S

That menu item creates a material.SubstanceMaterial and the properties only show a single "substance.params..." option.

I have the latest Modo 801. And I grabbed the latest plugin from:
http://www.allegorithmic.com/substance-modo

Cool plugin! I want to play :)

Hi,

As @teknoart.gb mentioned, that scene was done for the modo 701 plugin. I will be updating the scene with a new tutorial as we changed the workflow. We wanted to make sure that the new workflow was more future proof with new modo versions. Which I am happy to say is working in the 901 beta : )

In the latest build, you no longer have to select a material group, the substance item is now generated below the base shader in the tree.

@teknoart.gb Thanks much for the reply and info : )

Cheers,

wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja