Author Topic: [SOLVED]designer 2018.1.0 - so slow it is unusable  (Read 3899 times)

I just updated my version of designer to 2018.1.0 and it is too slow to use.  Hitting spacebar to bring up the menu takes a full 5 seconds to pop up.  When you start typing, you can type a whole word and after 8 seconds the first letter shows up.  What happened?

I am on my high spec work computer that doesn't have a problem running anything and has never had an issue with Designer or Painter.

Any Help?  New settings that need to be changed?
Last Edit: August 27, 2018, 11:47:02 am

I have no idea what is causing this, but I am having the same issue.  Searching for nodes is just as problematic.  You can't type in real time.  Like you say, it takes at LEAST 5 to 6 seconds for the first letter to even show up.


For my library window issue - the slow search field - I just went to the windows menu and chose "New Library View" and then closed the old one.  Now it's very snappy as it should be.

I just downloaded Substance Designer 2018.1.0 for the first time on my new PC and I have the exact same problem.

Has anyone found a solution?

I'm running an i7 8700K and GTX 1080Ti with 16gb RAM.
I've had no trouble with any other professional software I've been using.

Hi atomic_alex,

Can you send your log file please ?

Thanks !
QA Analyst

I'm having the same issue.  Starting with a new project, very slow or non responsive when trying to navigate filter/sidebar menus or dragging filter to the work space.

Modified registry per directions when installed for timeout limitations.

Threadripper 1950x
64Gb Ram
GTX 1080

Hi all,

I need your log file to investigate. Without it, I can't help you :)
Or at least can you all tell me if you are using the standalone version or a steam version ?

Thanks !
QA Analyst

Here's my log file and I'm using Standalone version.

thank you.

Hi all,

we solve the same problem with another user making a clean install of Designer.
As I'm still investigating on the reason of this problem can you send me your preferences and registry files before deleting them ? (using private message)

Here are the steps for a clean install :
  - first uninstall Designer
  - then reset all the preferences files. To do this follow this path : C:\Users\[USER_NAME]\AppData\Local\Allegorithmic\Substance Designer. Delete all the folder Substance Designer (or cut it somewhere else in order to make a backup if you want to send them to me).
  - delete the registry files :
  • in Windows search use regedit command, it will open the registry editor
  • then follow this path : HKEY_CURRENT_USER -> Software -> Allegorithmic -> Substance Designer
  • before deleting Substance Designer folder, right click on it and export them (if you accept to send us this files, if not, just delete them)
- last step, reinstall Designer 2018

Thanks !

Last Edit: April 13, 2018, 11:21:12 am
QA Analyst

Hi Celine,

Sorry, I sent my log via e-mail which may have gotten lost.
I tried your recently posted solution and it worked well for me.

Did you still want me to send through my log for your information?

Thank you so for you help! Now I can get back to it    ;D ;D

FWIW, I had this problem as well and a complete reinstall seems to fix things right up. Thanks.

So I've followed the steps, because I'm having the same problem, and the whole uninstall and reg_edit still isn't fixing my issue.  I'll press the space bar to try to just find a uniform color node and it just sits there non responsive.

*update* I've now repeated the steps above 3 times and still nothing. :(
Last Edit: September 07, 2018, 11:55:21 pm

I just updated mine and I am having this problem too. i did the uninstall and delete. Reinstall again, same problem. It's impossible to work.
Last Edit: September 15, 2018, 11:05:32 pm