Author Topic: Substance Painter Hangs indefinitely during bake  (Read 3730 times)

With this new update, I can't seem to get past the ambient occlusion map. And if I uncheck the AO map, it hangs at the thickness map. The resolution doesn't matter, and I've tried this with multiple models.

It doesn't do this if I bake onto something really simple like a cube. But if the high res is more than a few million polys, then Substance hangs.

I followed the instructions for Nvidia in the log, and downloaded the hotfix. This doesn't fix my issues :P I suppose I can just bake my maps in Designer for now, though I'd love to know why and how to deal with this problem!

Thanks a bunch in advance,


3D art is magic.

Can you please export a log file after a failed attempt at baking, and post it here (or share it by PM) ?

Im having the same problem with Thickness and AO. Aslo, should it be using 100% of my cpu??

The only way to escape is by ctrl + alt + delete to kill it. There is no log file   :'(

Substance Painter uses 100 % of my CPU and I can barely move my mouse.
3D art is magic.

The only way to escape is by ctrl + alt + delete to kill it. There is no log file   :'(

Can you "manually" find a log file following the notes on this page?
Common "Help" suggestions:
- LOG FILE tips -,22451.0.html
- LICENSING issues
- ATTACH files and pictures to posts:,23670.0.html

3D art is magic.

I was able to bake all the maps I needed in Substance Designer. Yay!

So it's strange that I can't bake in Painter, I thought the bakers were the same. I rarely use Designer for baking maps (since the model is in Painter anyway). Gotta say, I'm really impressed with Designer's baking tools. Wow. Even an opacity bake 0_0

Still, Painter is really beautiful software. I hope a fix comes out for this.
3D art is magic.

Having same problem have tried everything. Thinking it may be an fbx issue

 bug report (46253)

Could you guys by any chance send us the meshes you are trying to bake via private message?

Used 2014 settings on fbx, deleted all subdivisions from Ztool leaving only the highest. re-export seemed to help so far...

I was able to confirm this as well. ZBrush FBX exporter only goes as high as 2016, which for some reason only breaks Painter's AO and Thickness bakes. Setting the exporter in ZBrush to 2014 seems to work ok in the current version of Painter.

Welp, I've been baking the same mesh over and over to test, and even with a 2014 high fbx, it's inconsistent whether the bake will succeed or not. I got it to work a couple times, and then it just stopped working.

Please fix this as it is even affecting rolling back versions. I am having the same problem when I go back a build now.

I read on the steam forums that AO and Thickness are only using a single thread whilst baking.
Tried baking everything except AO and Thickness results in bake speeds that I've come to expect.