Author Topic: SD Nodes Keep Showing 0x0 - ??  (Read 3025 times)

I'm in my first hour of working with SD and I'm already experiencing bugs.  When I change the Base Parameters Output Size values, all of the nodes display "0x0 - ??" and the thumbnails display a useless solid color.  I've attached a screengrab.  I'm on a Mac Pro running an Nvidia 980 Ti card.  When I tried using Substance Painter a few months ago, it too was very buggy and I had to stop using it.  Is the Substance Designer problem I'm encountering potentially similar?  I'm wondering if I can continue using Substance products with my current configuration?

Also, I tried reporting the problem using the built-in Bug Report feature and when I pressed Send, it would not send.

Please help.  I would like to use your products, but can't seem to get any of them off the launchpad.


In your Preferences > Graph, can you tell me which options are enabled ?
Q.A Analyst

All options are enabled except for "Display comments at a constant size (zoom/unzoom)."  It's worth noting that, after several minutes of waiting, the thumbnails are updating and displaying the output dimensions below.  Is it normal for them to take so long to update?

Same, i never get the actual ms underneath and its annoying.

Same for me on a Graph that was previously build on 2017.2 release.

I don't know where this is coming from. totally stuck on the work with this.

Can I have your log file and .sbs if you don't mind sharing ? (everybody having this issue).

For your log file :
In Designer : Help > Export log file.

For your graph :
Right click > Export with dependencies (if needed)

Thank you.
Last Edit: February 09, 2018, 04:36:08 pm
Q.A Analyst

After experiencing this issue, I watched a tutorial that indicated that I could right-click in an empty part of the graph and choose Compute Nodes Thumbnails.  For now, at least, this seems to be working for me.

bug report done : ref bug-21e1321f

bug experienced on 2017.2.3 also. but more often on 2017.2.4
Last Edit: February 10, 2018, 01:10:34 pm

Can you send us your graph ?
Product Manager - Allegorithmic

I had the same issue today, and i can't find the problem. I reinstalled it and still the same thing.
All my graphs are this way =S

What version of SD are you using ?
Product Manager - Allegorithmic


Can you export your log file ? (as described above)
Product Manager - Allegorithmic

Hey Nicolas, thank you for your support! I just made this:

For the 3D 2D view issue, can you try to delete files that are here:
C:\Users\xxx\AppData\Local\Allegorithmic\Substance Designer\2019\databases

and it worked! Thanks again!
Last Edit: September 18, 2019, 01:24:44 am