Author Topic: Icon  (Read 3947 times)

Is there a set format for inserting a custom icon? (see attached)  I am using .png which shows in my .sbs file however is not present in my published sbsar files.

Thanks.
Last Edit: August 04, 2014, 11:59:42 am

I have the exact same problem  8)

I have the exact same problem  8)

Hey Mario and artzfx,

I think they icons are not supported in the publish of the sbsar file. I will check on this to be sure. I think the icon only works in SD.

cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

I have the exact same problem  8)

Hey Mario and artzfx,

I think they icons are not supported in the publish of the sbsar file. I will check on this to be sure. I think the icon only works in SD.

cheers,

Wes

Thanks Wes, in that case I have a second question.  How do I change a .sbs to be "ReadOnly" please?


I have the exact same problem  8)

Hey Mario and artzfx,

I think they icons are not supported in the publish of the sbsar file. I will check on this to be sure. I think the icon only works in SD.

cheers,

Wes

Thanks Wes, in that case I have a second question.  How do I change a .sbs to be "ReadOnly" please?

HI,

I confirmed that the icons only work in SD. If you are looking to share an sbs are don't want a user to be able to make changes, it's best to publish to sbsar. The nodes in the SD library are all sbsar, so if you open a reference, they are not editable.

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja

I am a bit confused...  If I drag the inbuilt Material Blend node into the SD Explorer it shows as a .sbs but is locked/ReadOnly.  This allows the Inputs to be displayed in the Attributes panel (image 1).  Would be nice to have this option.  I can do this with my own Custom nodes (image 2) but can't make the .sbs ReadOnly.

If I take your suggested route and publish a Custom node I create to .sbsar (image 3) then the Inputs do not display in the Attribute panel when I drag my node into a new graph. 

I am a bit confused...  If I drag the inbuilt Material Blend node into the SD Explorer it shows as a .sbs but is locked/ReadOnly.  This allows the Inputs to be displayed in the Attributes panel (image 1).  Would be nice to have this option.  I can do this with my own Custom nodes (image 2) but can't make the .sbs ReadOnly.

If I take your suggested route and publish a Custom node I create to .sbsar (image 3) then the Inputs do not display in the Attribute panel when I drag my node into a new graph.

Hi,

In the case of the sbs nodes from the library, their packages where set to read-only by the OS. So if you are on windows, you just need to set the sbs to be read-only like you would in the windows explorer for any type of file.

However, you should be able to see the attributes for the sbsar file. I have published sbsar file that I then add back to the library. Those sbsar files still have the attributes I set and are not able to open a reference.

Cheers,

Wes
Head of Substance Demo Art Team
the3dninja@adobe.com
Twitter: The3DNinja