Author Topic: Textures look error in Sbsar exported to UE4  (Read 1779 times)

I exported sbsar file and used in Unreal4.The textures have much more moire and not the same effect in Designer.I use Designer 2017.They are both 1024X1024 size in UE4 and SBS Designer.So I want to figure it out.Pls help!


The moire is caused by quantization. The difference is probably due to the fact that you may be using the GPU engine in Designer and the CPU engine in UE4. Switching to the GPU engine in UE4 should fix the problem.
Alternatively, if you must use the CPU engine in UE4, you can switch to the CPU engine in Designer as well and find out there which node is causing the quantization.
NB : the CPU engine only support 16bit greyscale textures and 8bpc color textures at this point.

Thank you very much,do you know how to switch to GPU engine in UE4?  I didn't change the settings in UE4,I always use the default settings.

Thank you very much,do you know how to switch to GPU engine in UE4?  I didn't change the settings in UE4,I always use the default settings.

Hey @jihanjiatc ,

This can be done by going to Edit -> Project Settings -> Scroll down to the bottom to Plugins/Substance -> Under 'Cooking', change the Substance Engine dropdown to GPU Engine. This also requires you to restart UE4 for it to take effect. :)

If you have any further questions, please let us know.

It works.Thank you very much! :) :)