Author Topic: Can't download from Substance Source [SOLVED]  (Read 2896 times)

Hi! I can't download any substances from Substance Source, either in Painter or through a web browser. If I try through Painter, I get a "Download Failed" every time. However, it does show up in the "My Assets" section, but I can't download them.

When I try through the web browser (Chrome), I get this error:

"This site can’t provide a secure connection sent an invalid response.
Try running Windows Network Diagnostics.

I also tried in Microsoft Edge, and it says I can't connect securely and that the TLS security settings may be outdated or unsafe.

When I run Windows Network Diagnostics, it can't find a solution. I have the latest Substance Painter installed, 2017.4.2.

Thanks in advance!
Last Edit: January 31, 2018, 04:44:58 pm

I figured out the problem - My antivirus, F-Secure, wanted to block the download. I cleared Chrome's cache, updated Chrome and the F-Secure browser extension for Chrome, and I was able to download afterwards.