Author Topic: Can't mask out Height detail on a Fill layer  (Read 8653 times)

I'm adding some scratches using a Fill layer and want to mask them but painting on the mask isn't working as expected. Rather than simply masking out areas I paint on, it paints in further height detail. Please check out this short screen cast and let me know if this is a bug / limitation or is there a better approach...



Hi John,

I'm also quite new to substance, but I think a workaround would be to put that layer in an own folder and give that folder a mask.
But I would be curious to hear from someone experienced the optimal answer.

p.s. nice video recording for asking such a question, which software did you use?

Hi Alexx, I've been using Substance for a while now but never noticed this issue. The folder workaround was the first thing I tried but that gave me the same issue. I use Camtasia to screen record.

Here's the solution:

Hi John,
many thanks for sharing this.

I think the problem is, that you at first change the layer default height before you added grunge scratches to the fill layer.
Because that means, when you mask that layer out, you mask of course also the default height level out (in your second video at 0.48 min).
Do you have to change this height, when you add the generator?
I think, if you wouldn't do this, the layer would work as you expected in the beginning. (but didn't try out, I' not at my workstation right now).
But the good thing of your method, to add the scratches to the mask instead of to the fill layer, is maybe that you can freely adjust that default height level and still painting out details.

Hey Alexx just gave that a try too but same result.



Yeah this is not working for me. I see in the video he has a simple fill layer with nothing in it, but mine has a material in the fill layer. It's not helpful to put in any other detail into the mask other than the areas I want to mask out. What is the official guidance on tackling this problem? My mask is not respecting my black brush strokes to mask out height from a material in a fill layer.

I made a very short video of my problem. I'm using one of the provided materials to give me that diamond pattern. It has a mask on the fill layer. The polygon fill tools work to mask things just fine, however when I attempt to hand paint pure black it has no effect on painting black to the mask. This is confusing the heck out of me.

Last Edit: March 06, 2018, 04:05:57 am

UPDATE:  Ohhh... I think my post can be 98% ignored, but I'll leave it below here, just in case anyone finds something of interest in it.

@John - Nice video.  Thank you.  Sadly, I didn't see it until after I posted.  Based on James' post, I was assuming an answer hadn't been posted, but I thought you covered it pretty well.

So... Is everything here solved, or is anyone still having problems with this?

The remainder of my post here can probable be ignored, I think.


I've had this post set aside on my computer for a few days, and finally got around to digging into it.  I think I have the solution your are looking for.

Add a "Paint" layer to your mask.

Right-click on the mask, and pick "Add Paint."

Then you should be able to paint out the "height" where you want to.
You can see I tested this by adding the "Aluminum Insulator" material, and (not shown) removed all channels except for Height.  I did that to make the height be more visible in the screen shot.

Handy short-cut when painting the mask:  "X" will toggle between white and black paint.

Please let me know if that helps.

Good luck.

Last Edit: March 10, 2018, 12:36:59 am
Common "Help" suggestions:
- LOG FILE tips -,22451.0.html
- LICENSING issues
- ATTACH files and pictures to posts:,23670.0.html

I found myself coming back to this issue again today. I have attempted to do exactly what you've done in your screengrab and description there, but I cannot mask out the height information. Any guidance on what I'm doing wrong?

Here is a video showing my steps:

Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

I went and found the log file text document. Hopefully this will give some insight into what's going on or wrong. Thank you for your help.

Can you try older drivers ? As mentioned here :,22711.0.html
And just in case, checkout our know conflicts with other software :
Don't forget your log file. It can be exported from the Help menu of the software.
Fabrice Piquet aka Froyok. Product Manager, Technical Artist and Documentation at Adobe.

Luckily I have none of the other software there that could conflict. So you believe this could be a video driver issue? I am always very cautious when upgrading or downgrading nVidia drivers as new ones can be unstable and produce issues in all of my 3D software across the board. So this older driver is proven and known to be stable across most 3D applications?